summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autodoc-typehints
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/sphinx-autodoc-typehints
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest3
-rw-r--r--dev-python/sphinx-autodoc-typehints/metadata.xml17
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.12.0.ebuild43
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
new file mode 100644
index 000000000000..7af13a89bc96
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-autodoc-typehints-1.12.0.tar.gz 19494 BLAKE2B beacc4f8ab453612dfd5264f1c65fd6bdd957269a28ee5b71b762d0baf5a3d4be58398b32d4263f996648281c1139f47a7564e8fc6444a94095f6a970b4cc27a SHA512 92fa340495a48111fa3d600d8c46d83214505ac2a5c71cb1303e846ac439f1e0ff14f8ce8dfd5ffdb6a62a9fa15dde8a5227f946840d9377ad5f7fde25894b75
+EBUILD sphinx-autodoc-typehints-1.12.0.ebuild 1059 BLAKE2B e5f0bfdd6407eaa0a7d75b382d8490c4d3247d6a9c462cf33b1fed561f9d71aa0f6ad63a486800ad38347c0d4daa07a04f5c39c56667a27cf72a3b631134f1cc SHA512 25def2a690338d12f83336d41bf481ae5758f6caeb110f53ff8a4a146705b4fcf7e32aed4ed9064951c4eed478e5bb8e7eb321e6b35a6ccf0fc5a2989f2b6d70
+MISC metadata.xml 701 BLAKE2B d1c41250ae7a9f233e1e208443b764522071d4d0ce3274b28ca95135c01b780d38faa88c8bba7ab7874584b420dc81c8b43e629718fd085d461bdcf755bb9e79 SHA512 952f4e2a940fe23acd47a9e0f101c6d78c6939fb9ad69920a9cf9770b44ba3dad7e65e708ca0ad54fac5ef871a18a737e9ed200a678210e93740eb065be81a0d
diff --git a/dev-python/sphinx-autodoc-typehints/metadata.xml b/dev-python/sphinx-autodoc-typehints/metadata.xml
new file mode 100644
index 000000000000..a8e231b705d7
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <longdescription lang="en">
+This extension allows you to use Python 3 annotations for documenting acceptable argument types and return value types of functions. This allows you to use type hints in a very natural fashion
+ </longdescription>
+ <upstream>
+ <remote-id type="github">agronholm/sphinx-autodoc-typehints</remote-id>
+ <remote-id type="pypi">sphinx-autodoc-typehints</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.12.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.12.0.ebuild
new file mode 100644
index 000000000000..1999e89a2278
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension "
+HOMEPAGE="
+ https://github.com/agronholm/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# https://github.com/agronholm/sphinx-autodoc-typehints/issues/176
+RDEPEND="<dev-python/sphinx-4[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # why on earth would this have to connect to the internet
+ sed -i \
+ -e 's:test_parse_annotation:_&:' \
+ -e 's:test_format_annotation:_&:' \
+ -e 's:test_format_annotation_both_libs:_&:' \
+ tests/test_sphinx_autodoc_typehints.py || die
+
+ distutils-r1_python_prepare_all
+}