summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-bootstrap-theme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-09 22:33:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-09 22:33:12 +0000
commit6147e25e3b1f6ce82b661605708d0b8292c03f47 (patch)
treeb8c60917145c0a076da1e88dd73edfaad594d5a6 /dev-python/sphinx-bootstrap-theme
parent3f5a5d10d87cd7f434c3a4207fc0a7ffc25d9123 (diff)
gentoo auto-resync : 09:11:2023 - 22:33:12
Diffstat (limited to 'dev-python/sphinx-bootstrap-theme')
-rw-r--r--dev-python/sphinx-bootstrap-theme/Manifest2
-rw-r--r--dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild16
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/sphinx-bootstrap-theme/Manifest b/dev-python/sphinx-bootstrap-theme/Manifest
index e0e231d1022a..018fc475cbe7 100644
--- a/dev-python/sphinx-bootstrap-theme/Manifest
+++ b/dev-python/sphinx-bootstrap-theme/Manifest
@@ -1,3 +1,3 @@
DIST sphinx-bootstrap-theme-0.8.1.gh.tar.gz 1228936 BLAKE2B 1f7d83052cd8f7b5cc8ec89279e591eab46ea3db11562dac8d92f9050b47fe5ab28939a17e4e48178096cd161275af7fb3047c91a4a5c405b9a8f848625893dc SHA512 de56b56bbb729c9d4f98697a1d312555ddb22c05588fb00e0417075f8b500a6cb09c8918276f4a59900ceec1374f1355cd4919b012505a37481de970f0172399
-EBUILD sphinx-bootstrap-theme-0.8.1.ebuild 582 BLAKE2B 0c84bea101771286fa60ba69138e6885c82388b4b4d80cabf2a14ddff32fc77c14993bb60de73bb1b8b528fd198ef50cf8644d1394d25adbe35e78a8736b585b SHA512 79ed3863256afe8559e15a6adf82b138aa60fa843c30fa147342d407b9107a82080ddd39695da42b4761ce889f93b6ff2b771bf8f01e8c10915464c68cbfaa18
+EBUILD sphinx-bootstrap-theme-0.8.1.ebuild 841 BLAKE2B 28c3b4f6a3de8a8768307fd482f978cc4c66805c1970d7a5aaf70d84b5d0b7ff1f6f530dd6b04e33afdfb031156222ccbd663de74aac5e7bb802e1b463c05d6f SHA512 024a14472d1b96fed7044d9ec479e580a5320cf15d184ba2e0c1cc9d4bf426f62ff3ac83862b7ff498d46b714d1e58e8dd9de53c7b11b5a7d49a7def8dd004b4
MISC metadata.xml 521 BLAKE2B 2748af332700ea3f04ea592b42e5b6e2b099efdac4385ad10672e3e0633b8625ced940d7f94e5c64d4798e29acff17c6e23a71c3d638d3be054fe872aa5409c8 SHA512 6e85d7ca107611051edff6f6f6187656de9d2d6d0faf90df838766a0068d0fa756f8afab992bd7c8de77f44b5f83a6c7b4cd03cbb7a434aabaf1bb8295019e6f
diff --git a/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild b/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild
index fd1fab5f0119..11ec27c0ee0d 100644
--- a/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild
+++ b/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild
@@ -4,17 +4,27 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Sphinx theme integrates the Bootstrap CSS / JavaScript framework"
-HOMEPAGE="https://ryan-roemer.github.io/sphinx-bootstrap-theme/README.html"
+HOMEPAGE="
+ https://ryan-roemer.github.io/sphinx-bootstrap-theme/README.html
+ https://github.com/ryan-roemer/sphinx-bootstrap-theme/
+ https://pypi.org/project/sphinx-bootstrap-theme/
+"
SRC_URI="
- https://github.com/ryan-roemer/${PN}/archive/v${PV}.tar.gz
+ https://github.com/ryan-roemer/sphinx-bootstrap-theme/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ cd demo || die
+ "${EPYTHON}" -m sphinx -d "${BUILD_DIR}"/doctrees \
+ -b html source "${BUILD_DIR}"/html || die
+}