summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-copybutton
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-29 13:40:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-29 13:40:31 +0100
commite745e1d281540da525df5eaae0904b62bc27852f (patch)
treefe71391505cd5188d417ddc468859a54f0c648ae /dev-python/sphinx-copybutton
parent05f2a11918a15ef57166e74d69d6c4737673e75c (diff)
gentoo auto-resync : 29:06:2023 - 13:40:31
Diffstat (limited to 'dev-python/sphinx-copybutton')
-rw-r--r--dev-python/sphinx-copybutton/Manifest3
-rw-r--r--dev-python/sphinx-copybutton/metadata.xml15
-rw-r--r--dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild22
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sphinx-copybutton/Manifest b/dev-python/sphinx-copybutton/Manifest
new file mode 100644
index 000000000000..019d22ad58ed
--- /dev/null
+++ b/dev-python/sphinx-copybutton/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-copybutton-0.5.2.tar.gz 23039 BLAKE2B 5a440865610dbcfc8abc8a10c38832439d5f588a26a8641374cada3cc181a0ba2a19e62b287a296c1879f25342ce8aae1ade080126f837e5ad9291c152a30c6e SHA512 83f61526d8a20f70b0de63a5bad89ed4ae4f3cf5cd589f1a1e2e91f08f4d45a05acf780a4cf3703d4490ab93c9c9bb18c11d3170b8011c2254aab0334940ab2d
+EBUILD sphinx-copybutton-0.5.2.ebuild 502 BLAKE2B dc432e7a9bb7e158373e821b69322b038783ed07eb564b8cb77066593ebbd19c91dbe56f273dc1f3e8b42037135bc29d07c2317072af249b0d04c80048810e71 SHA512 a208190a6199fb6606a89dad6763da6acf75eea1bf226d1bb705610435689164ac5ed86c5eccb4d8b75804c632ac24e63c95dde170977fa87a24f87c1e92ebff
+MISC metadata.xml 561 BLAKE2B 9b79bc70ff34e5be3453d71f1d9547f2c83096e9d7a32eb2dcf38d9868d766a7f7bceb6df1f28a6ac375a47ec2c7ff98008a99ef5233e85bcc3199f48f607e9a SHA512 3b1d64928d68a420b99470ecddcaaf3b36d8ddf3009d44e0580a15937c126e275938a5835d2900e2d30101034a2b2ba0fb1bb58cbda68fcf3cb84aaf36d50b25
diff --git a/dev-python/sphinx-copybutton/metadata.xml b/dev-python/sphinx-copybutton/metadata.xml
new file mode 100644
index 000000000000..343dee9179fb
--- /dev/null
+++ b/dev-python/sphinx-copybutton/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">executablebooks/sphinx-copybutton</remote-id>
+ <remote-id type="pypi">sphinx-copybutton</remote-id>
+ <doc>https://sphinx-copybutton.readthedocs.io</doc>
+ <bugs-to>https://github.com/executablebooks/sphinx-copybutton/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild b/dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild
new file mode 100644
index 000000000000..297c59d28f0d
--- /dev/null
+++ b/dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYPI_NO_NORMALIZE=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small sphinx extension to add a \"copy\" button to code blocks"
+HOMEPAGE="https://pypi.org/project/sphinx-copybutton/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest