summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-gallery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/sphinx-gallery
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest5
-rw-r--r--dev-python/sphinx-gallery/metadata.xml12
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.1.12.ebuild26
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild41
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
new file mode 100644
index 000000000000..8cdb460b9b18
--- /dev/null
+++ b/dev-python/sphinx-gallery/Manifest
@@ -0,0 +1,5 @@
+DIST sphinx-gallery-0.1.12.tar.gz 68976 SHA256 16ede5720d3d78631e20f47196fadf0f2d19d61908313160aa485557a7da0ccb SHA512 57e8fc3746c2f5c941ddc3e00c749a6bfa63fb5741b3e5551df02f798858c417acee05a6b35512506aa0c4866b14a093cb4269284501672c3bbbf2edfc1edc1d WHIRLPOOL bb550bb3eddad4f2d5902c91e0a0128d535f16e2c4981284c24f8fc8a004bd8af036a78ac24b05578d1a556b54f3972025494a1fe146985a0baa23895b68fc1b
+DIST sphinx-gallery-0.1.7.tar.gz 59166 SHA256 594da5b4ed08e6531798c735608f4fe65a8bd394ea3b7b9194d9e659e48a4ea0 SHA512 0c14d35ed07db3988c9f119037676752e3f793a74000d7397f49e5b749a96db77ff4ba2e9ceb12993650e0c81042899a5056f3181e5360a738a5c62259c58ff5 WHIRLPOOL a307ddb0e4b0844ec823399fd8d00ea7fb7aa55cf243c63d7d6ad151cf3285c1f48eebb7f8e8f78b329688e9c73b54b5be0c14fe1ce264896f50af4dddd9d7b7
+EBUILD sphinx-gallery-0.1.12.ebuild 659 SHA256 c2a9dad98ac16449c4df03293b15ecfa2f83fdb767db82893869372a1facc4ee SHA512 3a2922228e4f8b82e643c9bb1309dc8ecf4036b694fb537a9c88a23b74103924680ad925c25ecdcd09205fbf3397bb09ffd915b3edfc55cb51e3d83323fc2b58 WHIRLPOOL 4c22f020b3fc315fff9ce947db7fb2d7db2a6a338ea8dfc6886d1cddee455558e6e3940819eaa899edc763b8dd0ec7fd39ba2e45f99028d5a61ad4ab2f4f28ea
+EBUILD sphinx-gallery-0.1.7-r1.ebuild 1024 SHA256 5ac58f0bf1b7f671c2db8bf5155ba91171a6241eaa09de837780aba53a86885e SHA512 20775c5f7c446de598e7be56354f8ebeaf31f92988d3111a3a6b98d6eadd601ccea703a31c27d5aa18f6b92f7e365f357405c66778d57e6d19b26304715ddf2a WHIRLPOOL ae24d6277dd49dadf34bd27dc7800f9cd7d3db8b9bacabb2558a0ea96736cea736ce9c0636415b425988fc9f75808fe0221c7253f09eb98be41f43feeb5ec642
+MISC metadata.xml 398 SHA256 df69b643b1f882a8ae5cb5a84c206f27aa0ce2cec3de7318e7db97b5b9379e14 SHA512 3b9762099b163b539d7de52602291433608ef33a9e60d3713e07bcf0b2b8345a52a0b162f6be52c9a88cfd419e5bc4e59307d07213f1d5aa3c4ca892d91f8b9b WHIRLPOOL 73bfac12f2bf4548658d51a007e0749783a0bd858ef647b41acc6634e5956285ff79281f122402d24e1c6bba7b361b1a4505dae230644734193a68030125d21b
diff --git a/dev-python/sphinx-gallery/metadata.xml b/dev-python/sphinx-gallery/metadata.xml
new file mode 100644
index 000000000000..d2a56513871a
--- /dev/null
+++ b/dev-python/sphinx-gallery/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinx-gallery</remote-id>
+ <remote-id type="github">sphinx-gallery/sphinx-gallery</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.1.12.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.1.12.ebuild
new file mode 100644
index 000000000000..c4a8581f41cd
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.1.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="http://sphinx-gallery.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# tests need extra files not distributed
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..333d76c55a7a
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="http://sphinx-gallery.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+# yes nose is somehow required besides testing
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/nose-1.0[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # Remove setup_requires=['nose']
+ sed -i -e /setup_requires/d setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ echo 'backend: agg' > matplotlibrc
+ VARTEXFONTS="${T}"/fonts MPLCONFIGDIR="${BUILD_DIR}" \
+ nosetests -v || die
+}