summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-gallery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-21 11:12:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-21 11:12:11 +0000
commit5b68b3c83eeba9cd1f69f8bce1194794975b84d3 (patch)
tree4c15b5b55afc6d8a8fbe90de564321fb746812e5 /dev-python/sphinx-gallery
parent949b406c5d38689bd65345d9326fefd8e102d163 (diff)
gentoo auto-resync : 21:11:2023 - 11:12:11
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest2
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.15.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 4d312e10e654..ae6792f1bf1c 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-gallery-0.14.0.tar.gz 408734 BLAKE2B f527eb58b565353722d669edf81a667b7c3e784480500ff03b5567b9214c27951438052db3f2dcba92b24e7224d5cd0017bfbe770132dc96ce3427ca463329a8 SHA512 c8a69af9dec9adf042214de0cb48d510ebb41d7bc4bb1e5767f3982b0e83d9dfa1a26028d939a1785d3894894d396840e437dc5c196bfc5318152d06240d84b9
+DIST sphinx-gallery-0.15.0.tar.gz 422363 BLAKE2B cbca8ec252e03e9cacc0df27da43ebc9bbed8531d5df65bf9cb7f54f7ae8b127582f353cb245bcc459d6fa86240207346a05d777504163d49be0fabb029a172b SHA512 b6b0d5022da9de27417f8cc72ba24f0d51e57f83c68b17a296269b074888a711d61fcf933fbbfaf4d6977702b3f020d4b0eaa89e78e51185ee2dd26e911fe8be
EBUILD sphinx-gallery-0.14.0.ebuild 1434 BLAKE2B b6f1a91a59a0b84727f2bddedc3f942a3881f841d5975acc967e66eefdf64830f2ad9679ee8e8b788d0455cdd1ab1becae239244221b0bd7e8321ce3a8aa8985 SHA512 caee116f254bfe3a6fea32d7c71ffa9ef022a8884876f86a2b843dc2659115727b62d4ffae13c309c08fe8462cea69f48ff5634b9f789aded3e6a331b5c7e8aa
+EBUILD sphinx-gallery-0.15.0.ebuild 1437 BLAKE2B 65a87ad767edc64579cc98aa22409419bdfae2baa7257f655270b849f88a331b5e2747a5d9a0fc3c0377a288a1cd92b62b0c139e275133bc5ce50902b6311581 SHA512 94e20b681da9a8f21b322a2fa842dce672fbb560ae033bc31d93642d09d4558b7323983f47fdae2b67b8dc8b43c403e0cef68527c7e1cbc56b51cb3a61081bf6
MISC metadata.xml 424 BLAKE2B 4e5cd1e912fd5934c7221d3e5cc60b2894eca6b994384f6ceb8397ce9c5312be1e9869b57f9dd7f3ac66501b20e6fd6abd2f33b5d19b93d3a12f7158ba08e7c6 SHA512 17acc19bf43dbbf1a377949576252f77fd334ddd8a3bec593d2339db5a44e4fde831f9ce47be97318bf72e30a062608f883e48cf572904b3476fde0df33adb09
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.15.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.15.0.ebuild
new file mode 100644
index 000000000000..e4a9b5f96a09
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.15.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://github.com/sphinx-gallery/sphinx-gallery/
+ https://sphinx-gallery.github.io/
+ https://pypi.org/project/sphinx-gallery/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+ # require jupyterlite_sphinx
+ sphinx_gallery/tests/test_full.py
+ sphinx_gallery/tests/test_full_noexec.py
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_non_default_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_config
+ )
+
+ epytest -o addopts=
+}