summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-notfound-page
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
commit260722f712fe06c113e7b13ad2e924ed14aaf0c4 (patch)
treea29845500e555a40458a70b7ed2896588134df2a /dev-python/sphinx-notfound-page
parent0fde6d7108b1ee9fc6ad186eff4978faa255db20 (diff)
gentoo auto-resync : 31:08:2023 - 16:11:26
Diffstat (limited to 'dev-python/sphinx-notfound-page')
-rw-r--r--dev-python/sphinx-notfound-page/Manifest2
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index dc5fe71ab37c..e1d08c843daa 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-notfound-page-0.8.3.gh.tar.gz 59219 BLAKE2B cdb95906dba4d51aee88b220f094204575f2800737f160c7c028033002d41d2c793a91e1c61101f7c7c960ddf3b4d2ef83fbd285dd73ff5aed6c6c933b1fc1e7 SHA512 8d43ccfd3f83ff25b7a20ee3f5352489092dc641b4a794199c06c0971078a132a42b05c85588508ec38487f2915eedec98c2deac02d6c4576828be2fbc7f13b0
+DIST sphinx-notfound-page-1.0.0.gh.tar.gz 543729 BLAKE2B 87da323277a38b20d43fa23e67528fee9530a243aa557a2be279a4a6877ac18bc36546beba0c6cc4ff598410d4be3a4337c7508005064df52867dca2675c8a3d SHA512 e9d235fb0461ee9f349a57d37caeaf4cb4ec5faab7e731067e69467bf0990d5c5ce31d024fe2ac531fb84f49a4e2e74092ce09d5977135c759669523fc59ab4e
EBUILD sphinx-notfound-page-0.8.3.ebuild 843 BLAKE2B 559f634207064895b67d2469cc3884d8d91f5c993f3a6cde7080ab2ad4a8926c3f5b717e244f59e4f36260fc79af52ec6c006ae3080613cb644c2a5320e820cf SHA512 f0299dfaa2d8d5e9b0b5514ffadad7c3f0f4f1a4ba94211e902124208cde9832281cbaeb85e44b2c8253f0e8bd5fbbaa5392b98d1cadc06487b57898301220af
+EBUILD sphinx-notfound-page-1.0.0.ebuild 856 BLAKE2B 586e16a8935f1febff7eb21fd4ea02d7d9b5a1185cd68c80cab7b3fb3e85b55685b43ac99b339b86b9da1f1fbbf91d81899806be88405f13df29ebe790e0e7d9 SHA512 a9c92ce2c2cd2c5e2c11b12e93c94285c75ffc814e0e48bd8d33a965940fc569acb19b9fd5022540d471f13ccc0c8bde97a63af1314273a582ecfb0f99c72038
MISC metadata.xml 651 BLAKE2B 7b4c1c58782b6a1e6118744d4933d8bfc1391fef578350f9622dddfb911a4319be8fc2cd2a297d5ac84bb97249d520a1cb740ed00d6314cb3cbf1dce5c119dfd SHA512 4b531fde722c6f0f0709405669efe61cfe2fd14e52f627ee67001b81d5268444b226630f55c6dc6a149ea86699379289368826429754abbad6cdaf36f1f4a673
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.0.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.0.ebuild
new file mode 100644
index 000000000000..f811d8c620b2
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded"
+HOMEPAGE="
+ https://sphinx-notfound-page.readthedocs.io/
+ https://github.com/readthedocs/sphinx-notfound-page/
+ https://pypi.org/project/sphinx-notfound-page/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # calls sphinx-build directly, works around venv
+ tests/test_urls.py::test_parallel_build
+)