summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-notfound-page
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/sphinx-notfound-page
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/sphinx-notfound-page')
-rw-r--r--dev-python/sphinx-notfound-page/Manifest4
-rw-r--r--dev-python/sphinx-notfound-page/metadata.xml9
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild22
3 files changed, 31 insertions, 4 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index 4806e7562cdd..ddd78d69c77f 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-notfound-page-0.4.tar.gz 5685 BLAKE2B 0bfc6cf98e0731a5cc95f1802dad1e7297ed764a626831b970d75d82ec0f7d6edb45c404851ea13bf38decc39aabf0e3dd6b136714a591e8ab595f11e23e67cd SHA512 56e867e6954f26da498b77e8fa43e8d62961ab33ee9c16d2084745dd54a998df51c7d882a47560196135d2fb4d473f7305ef19b31373bc205f8eaf0d3d4946f0
+DIST sphinx-notfound-page-0.5.tar.gz 47806 BLAKE2B 4715bed7509970f9198a0c666a568ca403157ad0704d0e1d17d222e6e8dc7adefab3922a4b79e056d20034463d5f034cba8c7b65248569a46866a964abec7e70 SHA512 a48cf4bcc755687c9e02482727ab2c28abe314118cef775e6b5625e2db67e4040745740c3c9fd88206bf050f1621ef20ffb0262ec614c11497ef030f9fb675a3
EBUILD sphinx-notfound-page-0.4.ebuild 514 BLAKE2B 32325c5bd2224450f430332b74793a1b009e9c77358cd2ee54ec1f4aee9dcb4d7b1b8e448dd5a3e4cb10ed7534aa43b5f08c3211596a2fb4e8d79698af2ec998 SHA512 6faac5bb77a4ce6bbf704a45278242ba73160637af47b4ff26d9d8093d06e91ff13cbbbb336262a8221d75fc21860039d8e5ba3702ce9f0cd9df452c4fa27abd
-MISC metadata.xml 440 BLAKE2B 0a08957b47eac83866fdbfd2fc137fa09413c2f6e4cbe961a0c587cb1604951d76061d41acae0a925a9f1775c785e8dc0808255685c14d88b5543e729052aeca SHA512 84b278d6a84dccb896c1e5c10ff1018ec801ea1a36083896f08629db28e82f8b20be2cad95a13b2ad53ba3751c9f6ba0c8a6367ad9baeb2881d22211793c2671
+EBUILD sphinx-notfound-page-0.5.ebuild 646 BLAKE2B 9a55bfbd0eb3caa9e2f657e3ed7480a2f21762fe1f77252da0c76b480a40193e8561968baba4cb3ff4244308417166c65189001fb51828f5c1f07b87b8102b23 SHA512 f00c1b89941ccf18a8ff239d840badf65c9938c356c5f21b557884738cae539119287763eeaec59b1008de4273b894675614c7c3e93df2ed5f698a48f1175cae
+MISC metadata.xml 626 BLAKE2B a9cc30ad83ffd4e697b10525cd5d5d555ed6293ff54044a67eeb871f29d9683c5330c4c49c378c990e126db241fbca487d00510960e8154f74b1fcd50325dfe7 SHA512 3c92f220c2a0d3668c1c0d968f43cc5986494130952aec2d014900576f39fccb67953c1f8fe90e70d0591ee618e2b3b312828c436f3acf6ed75425d4f4694048
diff --git a/dev-python/sphinx-notfound-page/metadata.xml b/dev-python/sphinx-notfound-page/metadata.xml
index 7f94ee92d1e7..f7ae32667577 100644
--- a/dev-python/sphinx-notfound-page/metadata.xml
+++ b/dev-python/sphinx-notfound-page/metadata.xml
@@ -8,7 +8,10 @@
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
- <longdescription lang="en">
- Create a custom 404 page with absolute URLs hardcoded.
- </longdescription>
+ <upstream>
+ <remote-id type="pypi">sphinx-notfound-page</remote-id>
+ <remote-id type="github">readthedocs/sphinx-notfound-page</remote-id>
+ <bugs-to>https://github.com/readthedocs/sphinx-notfound-page/issues</bugs-to>
+ <doc>https://sphinx-notfound-page.readthedocs.io/</doc>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild
new file mode 100644
index 000000000000..6fef53b3f911
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded."
+HOMEPAGE="https://sphinx-notfound-page.readthedocs.io/"
+# PyPI tarballs lack tests
+# https://github.com/readthedocs/sphinx-notfound-page/pull/110
+SRC_URI="https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest