summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-notfound-page
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-29 22:43:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-29 22:43:19 +0000
commitfa19575643c607e28b1572821c413ad7cb8eea09 (patch)
tree9d9b05acd34c77d7708182eac258ad26975949c7 /dev-python/sphinx-notfound-page
parentfc4ad6e568738af8995c2e87896c671c39eb8c72 (diff)
gentoo auto-resync : 29:01:2025 - 22:43:19
Diffstat (limited to 'dev-python/sphinx-notfound-page')
-rw-r--r--dev-python/sphinx-notfound-page/Manifest2
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-1.1.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index 0d60959fe536..da9c3e3a938a 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-notfound-page-1.0.4.gh.tar.gz 544117 BLAKE2B f8155167183fa3d6487cfd9f93eff8a99dd3253ed7f44632ca822b9da3d0b409a6897edd4f972fc9535b4759c2ef976c5f66daf85249ba9de4c83ae96ff65d7a SHA512 d6643e29768b31834c73302f8995cd92c052b2a51a4ecffc997f4ea4d15cf830c17a2f538fec637b1a3a7e187fa787252652b5ab8ce0ab92f44996a63669b504
+DIST sphinx-notfound-page-1.1.0.gh.tar.gz 544169 BLAKE2B 4a5aa18f0b566e43f2e9a5c0a25e8a19487a626430bfa53df75a573db09e943edd8b33d9948d983a7e6e07807e9e4257c241a6b63818d7d35a93aa4620c29e4c SHA512 4f6868e68e821f02020104aadc38c3b8d4e4f16eec8fc696e076ef13a49a3675560a8c90f2d0a1d5daf8ef4bee85ecfb61b2c03882c7be3aca000d34e13d5e68
EBUILD sphinx-notfound-page-1.0.4.ebuild 1371 BLAKE2B b84e59cab13b6d6d43ce3f7ccd9bcbae7f8aba2eb418df408aef17c6d9a553ac501b16320493e481dce6efbb38c0f3cb5d94be693fe856533fd38147ccac32df SHA512 fcece41ab826dc2b691e3cbfe3a0102588c7592236e39e0e2847063e0c30c027743382fff1062a53f81c753eba6c89e497b3419ded003999aa0635cd18105fe7
+EBUILD sphinx-notfound-page-1.1.0.ebuild 1379 BLAKE2B 8addd1b44a088bcb26e5af113750eee7cc2b150068b8ab25bb2d532cf5d555addec119921116e502dec3844a55a716e83de4c46aaf0c6e92b2888b07f9e49125 SHA512 7720b8053c71d721277ed2c4bd0ef4f19a682dc5cc9d2638929c939a6057f228b84215873bd2d682fc52a38bd2425d9c4c254de90203e49f50ef26359179d007
MISC metadata.xml 651 BLAKE2B 7b4c1c58782b6a1e6118744d4933d8bfc1391fef578350f9622dddfb911a4319be8fc2cd2a297d5ac84bb97249d520a1cb740ed00d6314cb3cbf1dce5c119dfd SHA512 4b531fde722c6f0f0709405669efe61cfe2fd14e52f627ee67001b81d5268444b226630f55c6dc6a149ea86699379289368826429754abbad6cdaf36f1f4a673
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.1.0.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.1.0.ebuild
new file mode 100644
index 000000000000..cc9efea474e2
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded"
+HOMEPAGE="
+ https://sphinx-notfound-page.readthedocs.io/
+ https://github.com/readthedocs/sphinx-notfound-page/
+ https://pypi.org/project/sphinx-notfound-page/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # calls sphinx-build directly, works around venv
+ tests/test_urls.py::test_parallel_build
+
+ # broken upstream (mismatch with new dev-python/sphinx?)
+ # https://github.com/readthedocs/sphinx-notfound-page/issues/249
+ tests/test_urls.py::test_default_settings
+ tests/test_urls.py::test_urls_prefix_setting
+ tests/test_urls.py::test_urls_prefix_setting_none
+ tests/test_urls.py::test_custom_404_rst_source
+ tests/test_urls.py::test_urls_for_dirhtml_builder
+ tests/test_urls.py::test_toctree_urls_notfound_default
+ tests/test_urls.py::test_toctree_links
+ tests/test_urls.py::test_toctree_links_custom_settings
+)