summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-selective-exclude
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
commit71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (patch)
tree4eccd905f575579fe47abb8a83bbdb44ceb8c929 /dev-python/sphinx-selective-exclude
parentc7a7ec40cf928d8fc6a8241aa208272c008c7b4d (diff)
gentoo auto-resync : 23:11:2024 - 03:02:56
Diffstat (limited to 'dev-python/sphinx-selective-exclude')
-rw-r--r--dev-python/sphinx-selective-exclude/Manifest4
-rw-r--r--dev-python/sphinx-selective-exclude/files/sphinx-selective-exclude-description-file.patch8
-rw-r--r--dev-python/sphinx-selective-exclude/metadata.xml17
-rw-r--r--dev-python/sphinx-selective-exclude/sphinx-selective-exclude-1.0.3-r1.ebuild20
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/sphinx-selective-exclude/Manifest b/dev-python/sphinx-selective-exclude/Manifest
new file mode 100644
index 000000000000..76aa753f1a22
--- /dev/null
+++ b/dev-python/sphinx-selective-exclude/Manifest
@@ -0,0 +1,4 @@
+AUX sphinx-selective-exclude-description-file.patch 356 BLAKE2B dcc2fdab9ad8f62d9a451625630b86bc103e4db1cc2b356884857c2272379a84bf3f99e64a9e85106e037351a5b79ea773b8b790f84a9f106c8aa4ed96706b2d SHA512 7d1e69d4631ce11e891e89e9e762c166846f03747ce18e923ec58d7a4e343e350705ee94d60aedd17ef4e520f821d277936b85d6589b9e7c83e044a0ef39beba
+DIST sphinx_selective_exclude-1.0.3.tar.gz 7227 BLAKE2B 90ba94f81e6dfc00a39bbcaf50d136c01c7b756bcb9366ab111169913fb2a571b7924afc89fd8fffc9cf7c96bc64cd2737441bd5228fe22f9e5a9687b5b4ae52 SHA512 8ceace1502948caa17bf611786132720093b818039b399eb832c12dc47ad86219610495698692c2c25a98a8ede8695a66b02f5e3bb6ea2c7d2410e275cd959f9
+EBUILD sphinx-selective-exclude-1.0.3-r1.ebuild 475 BLAKE2B 7e0aa79f672c87aaa781647741017e74b2f12374ffb0f3284fd6e269cc852bed61756b03d3199432920708ce140cf34fe88d59bde0256d26c59fbb49ec7296ac SHA512 3a2e4b1d3f384b5bbf727b008b1ed9fe13edbc69cba90dc3b426df5014e7f2ec88db8d535b8f7e54af2f51b0e3cd8604a09c5acdc58a5501adf3574b261c9d7a
+MISC metadata.xml 550 BLAKE2B 4867cc74e1aeb06987b473bd69c3e32954e027a9b03dac41f3394781ce75126a525b96ab56f0552200670073cc061266efdd72a6fda0afffe2e8bd0dcdd02a0f SHA512 e151a82302cd942e28c626234df6ee093775625d3f0d2bcadbb23db58f0ffa436c225016e05c3c78dcbf410536ebc6beffe3ffbd078f182dcda7e8bc5c51acef
diff --git a/dev-python/sphinx-selective-exclude/files/sphinx-selective-exclude-description-file.patch b/dev-python/sphinx-selective-exclude/files/sphinx-selective-exclude-description-file.patch
new file mode 100644
index 000000000000..cc81f571d8f7
--- /dev/null
+++ b/dev-python/sphinx-selective-exclude/files/sphinx-selective-exclude-description-file.patch
@@ -0,0 +1,8 @@
+diff -r -U1 sphinx_selective_exclude-1.0.3.orig/setup.cfg sphinx_selective_exclude-1.0.3/setup.cfg
+--- sphinx_selective_exclude-1.0.3.orig/setup.cfg 2019-12-24 05:59:33.000000000 +0700
++++ sphinx_selective_exclude-1.0.3/setup.cfg 2023-02-28 17:56:05.055719498 +0700
+@@ -1,3 +1,3 @@
+ [metadata]
+-description-file = README.md
++description_file = README.md
+
diff --git a/dev-python/sphinx-selective-exclude/metadata.xml b/dev-python/sphinx-selective-exclude/metadata.xml
new file mode 100644
index 000000000000..3a632fdb9d59
--- /dev/null
+++ b/dev-python/sphinx-selective-exclude/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">sphinx-selective-exclude</remote-id>
+ <remote-id type="github">pfalcon/sphinx_selective_exclude</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-selective-exclude/sphinx-selective-exclude-1.0.3-r1.ebuild b/dev-python/sphinx-selective-exclude/sphinx-selective-exclude-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..44b93c83a3e7
--- /dev/null
+++ b/dev-python/sphinx-selective-exclude/sphinx-selective-exclude-1.0.3-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx selective rendition extensions"
+HOMEPAGE="https://github.com/pfalcon/sphinx_selective_exclude"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-description-file.patch )