summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild')
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild19
1 files changed, 4 insertions, 15 deletions
diff --git a/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild b/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild
index dfd06d45edcb..e951c6617be7 100644
--- a/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild
+++ b/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -13,20 +13,9 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- # NB: while tests don't stricly use nose, they rely on some side
- # effects of using it
- nosetests -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests nose