summaryrefslogtreecommitdiff
path: root/dev-python/sphinx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-26 00:07:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-26 00:07:28 +0100
commit994fe442814c4d169bb0f1ee9745604928006b39 (patch)
tree630f10f7414f44018095dd9d3cf9df55852a9d41 /dev-python/sphinx
parentf8999218b5a6eafa151e7367030cbfdb69e045ed (diff)
gentoo auto-resync : 26:05:2024 - 00:07:27
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/Manifest2
-rw-r--r--dev-python/sphinx/sphinx-7.3.7-r2.ebuild11
2 files changed, 11 insertions, 2 deletions
diff --git a/dev-python/sphinx/Manifest b/dev-python/sphinx/Manifest
index 280ab15775cb..d4e96bf8ba78 100644
--- a/dev-python/sphinx/Manifest
+++ b/dev-python/sphinx/Manifest
@@ -4,5 +4,5 @@ AUX sphinx-7.3.7-opt-defusedxml.patch 1427 BLAKE2B a28078b9ec5304b4c1fba687b83b2
DIST sphinx-7.2.6.gh.tar.gz 7067425 BLAKE2B 4da1cb5ccebea4df0dc134c552311d7b70ce9b76424ea4355ad67b1ece60c9b445e56c96b838832d4df2f50940832b3fa9555b596390464a4017a573bcf514c3 SHA512 204e859318ad5044639f2e682098b07c7cc675b54ba801feeb3322290bfd15316cc15a2cae8fa6a55e6ec6d1e9690790e5402652eb04720bfe96e172f4c8bdbc
DIST sphinx-7.3.7.gh.tar.gz 7165383 BLAKE2B bcc68f26937e6aefe60cedea533a5c8e245c76b59ab4913fb6516f285e3afc32be60b336c662ac8305fb88e82fcc2b477128f2d8b9bf92f037b124f4c855df2a SHA512 540553ecddc55b3e673c79bc776a899d2c660f1e93ef819711be52174accf5b70465883a46bed81d163534e56718caf0765b4bae153e9307a3792387d8228df5
EBUILD sphinx-7.2.6.ebuild 4353 BLAKE2B 4e6f4767fd2b2f7de9174a745fc40c926af6acd89f62423bfa284721601a95c95694472e7b77be2a029860625821b33f11049c151cfd5c04e23a85c06a7def40 SHA512 73efc9db67471cc131fcaec408545dfdea8a04122efa57878062964d2b887fc2e8c6f5cca0d34ee321feaf9d1a77e72cd2ff4db8c0a5d7d2318fd7012d7865ab
-EBUILD sphinx-7.3.7-r2.ebuild 4619 BLAKE2B fa6834d66d55f3bfdcb15908522b2ea1ef83220f18f63ebda697a657a776e88fc4a1b92842782f46afe6c01f738f87b22b8a529323c0a6b35ba38556f30bdf38 SHA512 b996ba6087c1ae689a4ad17b79dd138376786da5e6e49e6776a188573c9317b34962264c42d8c9a5bb508c5162c76801ae65eaec2c0a4f475df98507b696c563
+EBUILD sphinx-7.3.7-r2.ebuild 5096 BLAKE2B cbe3411434d8d86540df1506bd5941d7224434356301ab7e72942c1d393e1d8631499f1a06aafd9cfabefa86a1e09f70e079a36d645da182fac0629ddc6c2763 SHA512 0387c13bc19de8ca07f092291df08ab529f08ab0537e69567263400f8bb2a715c5169d3967c4d5f0f361472eda337d2a3fd6dcdb69a32a72264fbbd74ca25bfb
MISC metadata.xml 568 BLAKE2B ddb7175070df6da4088813cc6b66f25bb4364e2619b1e7da94370f7ce8e73b68b12f618412f81e6be57fcb0c60c10e3913f26a6a578b0f9defa7b9ee8091fcde SHA512 d32b37cbe88f5e3db0c6968bc7aa22c7edfb3794bf7c62facd17e7ae1f4f0fbfc7c9f5512230cce16ed32e2ebb70c23dfe9b36ce38785c5f5b76585410313214
diff --git a/dev-python/sphinx/sphinx-7.3.7-r2.ebuild b/dev-python/sphinx/sphinx-7.3.7-r2.ebuild
index 99ff0e4980f7..036665b3e9fa 100644
--- a/dev-python/sphinx/sphinx-7.3.7-r2.ebuild
+++ b/dev-python/sphinx/sphinx-7.3.7-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -98,6 +98,15 @@ python_test() {
local EPYTEST_DESELECT=()
case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ tests/test_extensions/test_ext_autodoc.py::test_autodoc_special_members
+ tests/test_extensions/test_ext_autodoc_configs.py::test_autodoc_type_aliases
+ tests/test_extensions/test_ext_autodoc_configs.py::test_autodoc_typehints_format_fully_qualified
+ tests/test_extensions/test_ext_autodoc_configs.py::test_autodoc_typehints_none
+ tests/test_extensions/test_ext_autodoc_configs.py::test_autodoc_typehints_signature
+ )
+ ;;
pypy3)
EPYTEST_DESELECT+=(
tests/test_extensions/test_ext_autodoc.py::test_autodoc_exception