summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-applehelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/sphinxcontrib-applehelp
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/sphinxcontrib-applehelp')
-rw-r--r--dev-python/sphinxcontrib-applehelp/Manifest3
-rw-r--r--dev-python/sphinxcontrib-applehelp/metadata.xml11
-rw-r--r--dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.1.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-applehelp/Manifest b/dev-python/sphinxcontrib-applehelp/Manifest
new file mode 100644
index 000000000000..c1b11c7e6525
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-applehelp-1.0.1.tar.gz 22086 BLAKE2B 6e10329a1712cfcb1f29a3b4c23be5169507398a43f800623f2b24fd350f7e2ad16a887e87a3b68253dc348337342d3d4397d3a9d81a460c389a77ed4bdc973f SHA512 a6500bc2899f25c0b04c8649e86a6f688823e573a3f58f2b786117768e8b415acffbe79b99cff8aeb6ae3c74dd244254de120b82b7432cf61c5fabdd38f21603
+EBUILD sphinxcontrib-applehelp-1.0.1.ebuild 758 BLAKE2B 1406ba5f3073674d7470c4d21d3ee9f0fcd766984567f36f8e484f857d2e30775ad0c7a834de493f300216205f47f98c8780bce5d9b9f67c2a601ae9f8fcefa1 SHA512 4f7cc29d109190fb952ae33150905c36b0b511e758fe08e6f10cbf5c1e4a16e364c3a851317ce8592a8191e76d1a7213f0a78c669b4bcbf117efeab7439afd88
+MISC metadata.xml 326 BLAKE2B ad14acf80a55c014b396340b6f42885185c7059c9b2159662d0291c9fbc4b03b9000b612d53fd2d95eb861b410d35ca301cf00bde26ea3344219923ba1fbf3b1 SHA512 55187b429105dff1f05c80cf935da48c02fcf8b00dccd572a562d75fdba50b73183d2781d67c498c2fee181707eb32e09e7e5dc12a88e7bdfa7212f916c45543
diff --git a/dev-python/sphinxcontrib-applehelp/metadata.xml b/dev-python/sphinxcontrib-applehelp/metadata.xml
new file mode 100644
index 000000000000..5f2f3cd24f8e
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-applehelp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.1.ebuild b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.1.ebuild
new file mode 100644
index 000000000000..3cb06e3f8cc2
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs Apple help book"
+HOMEPAGE="http://www.sphinx-doc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND=""
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}