summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/sphinxcontrib-asyncio
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/sphinxcontrib-asyncio')
-rw-r--r--dev-python/sphinxcontrib-asyncio/Manifest2
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.3.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/Manifest b/dev-python/sphinxcontrib-asyncio/Manifest
index 0450654ab3f2..7477a5ce4fac 100644
--- a/dev-python/sphinxcontrib-asyncio/Manifest
+++ b/dev-python/sphinxcontrib-asyncio/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-asyncio-0.2.0.tar.gz 10689 BLAKE2B 9e03989a1ed22d7d467bdb7626e2e908407a0de15a943a432ff9707340f0cefe7caf1684380c25764637798b585b32287c4bcfc0f2014a78b7019547405e7ded SHA512 2ca25717c03385ae9bf879b8efeab8d508292d07f96d941032720d755d3db2e7bbc3c9a33c6103af9d83849ed8878bea1048d349bd0873288ee2addfee9756b7
+DIST sphinxcontrib-asyncio-0.3.0.tar.gz 11622 BLAKE2B 8c3358ad191e12e79767be6e6f3800e5de423d9a5ad005bdb416aa7a601cddc5f115db3e9b27213c06dbc341b671cbacd00217b65496baada40bfe257069abfa SHA512 fa66a2a9b5f89327686481f46d8e5be0b674f6355c8c0eeb862bf0ca0b5bb848121c5ed153780f653242faf1b82debc6917c3f6046244cce0f1423303a324f29
EBUILD sphinxcontrib-asyncio-0.2.0-r3.ebuild 908 BLAKE2B a6b3979a77ca6e00373cb1b6546e843657d195d23196033d892189754cbd686bf9e444bf931641baa21e51493b0f9bb9aca25956ca057302c58cacf63e0624d3 SHA512 592c3da169da3f3061b07d563515805dfca99bc90ee509d2ac251b959b8a888dd2ae53bd37d8b51253acff357273701ecdfb0ee43c7d3fcc02629f06457c63ec
+EBUILD sphinxcontrib-asyncio-0.3.0.ebuild 969 BLAKE2B 3e49eb341d332f5b01c2f661202b5eb61b4c9438e4af3e4a9686f1aebd35e119e6535ce3bb2485a6f89f99b84430012dda425000a48a72ada9126c7dd61923ca SHA512 35c5f17a139b97f659e3a1f583f471e9bbb103f5072eb9a3a7ccac685cefd27efba23a026667c5d337d922f8e4327b9d059fc422afd4b0dac82329137026e41e
MISC metadata.xml 397 BLAKE2B 357224874a9e2de147a2cc2a85350092fcd6189b1a3cb6cd1934c7eb922a9e0fb289776b65189dac007be1e663c3f98c73e656b5ab3677524bfac9329d41a542 SHA512 558c76f15358bb40e1c0a68750772487a3176b44f4f8ab046c0c8173d2fc0535516bd5dc4606646467785014a3e879ed7e31d5ccd10097741b02009c53042afe
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.3.0.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.3.0.ebuild
new file mode 100644
index 000000000000..b4063a15cf88
--- /dev/null
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="sphinx extension to support coroutines in markup"
+HOMEPAGE="
+ https://github.com/aio-libs/sphinxcontrib-asyncio/
+ https://pypi.org/project/sphinxcontrib-asyncio/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+
+src_prepare() {
+ # fix for sphinx >= 4.0
+ sed -e 's/PyModulelevel/PyFunction/g' \
+ -e 's/PyClassmember/PyClassMethod/g' \
+ -i sphinxcontrib/asyncio.py || die
+ default
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ rm "${BUILD_DIR}/install$(python_get_sitedir)"/sphinxcontrib/__init__.py || die
+}