summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/sphinxcontrib-asyncio
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/sphinxcontrib-asyncio')
-rw-r--r--dev-python/sphinxcontrib-asyncio/Manifest4
-rw-r--r--dev-python/sphinxcontrib-asyncio/metadata.xml1
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild20
3 files changed, 13 insertions, 12 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/Manifest b/dev-python/sphinxcontrib-asyncio/Manifest
index 84eded1133f4..08bd9c78da40 100644
--- a/dev-python/sphinxcontrib-asyncio/Manifest
+++ b/dev-python/sphinxcontrib-asyncio/Manifest
@@ -1,3 +1,3 @@
DIST sphinxcontrib-asyncio-0.2.0.tar.gz 10689 BLAKE2B 9e03989a1ed22d7d467bdb7626e2e908407a0de15a943a432ff9707340f0cefe7caf1684380c25764637798b585b32287c4bcfc0f2014a78b7019547405e7ded SHA512 2ca25717c03385ae9bf879b8efeab8d508292d07f96d941032720d755d3db2e7bbc3c9a33c6103af9d83849ed8878bea1048d349bd0873288ee2addfee9756b7
-EBUILD sphinxcontrib-asyncio-0.2.0-r2.ebuild 1050 BLAKE2B 066303c661736e62c932ff00c0dd9a48e86f2a6f4bb4cf99b506e9fe6f3a87933489486594e117901a7d4dcdf4db6608ef7742420d15dff26a96ff5a8f0d5141 SHA512 27c63f0e672c3c09b9d02ac3cfb40454d77f76174250c6081230d90323f242df61c1a084cc1fc4e29b3e2195f75f1c1b981ef98973373eacb0a90e7ebb1ae8db
-MISC metadata.xml 372 BLAKE2B 68f844dbb9c910e8df3e4efa74b074a01c6f0f1e0bde6a13f4e98303d917a3f49769f0b49be53e2c76429a3f3648a29f59de17d5ce3661aa24802fdc74a40d48 SHA512 f67668ca0e50834df86b7467d793c197dec76691efd10f3ceaa8fcfebd965c67351207e496c21e3f5acdcf0ebf474cd52d329ce9d05a9b8508397b5186ee885e
+EBUILD sphinxcontrib-asyncio-0.2.0-r2.ebuild 1036 BLAKE2B 62ca9a2056cb147d234c289e52ee70081607aea9babaae56088eb4a09d3c9beaa57527c8b48716c95511f12b12a7ba3a7fc20885563ce0b48e66437c49d11b99 SHA512 83780932985f1b2886c3a8381267cb4caeadc4241f0dd41dd70ed003cbfab280f5b091b110a78fcde0492a3309fd198ad8f0fd097f7bf0170f92af41fd9fab92
+MISC metadata.xml 396 BLAKE2B f34b84a48a20692e0f5aa18e04c888a6c0fc2cef7dff1b59163ea072cb7801a0cb88a440d1d35a263875ac581474560a87f6931bc0ce225f5aa9a62a26fec920 SHA512 06db15e4cf3060467d4def301c81eb717489e6953e774a0a4612e5c583f96aefbabf210fd0bc5d24b23cfa37b3a3cb740835a9d795ec05e4f860c5e5c3138a29
diff --git a/dev-python/sphinxcontrib-asyncio/metadata.xml b/dev-python/sphinxcontrib-asyncio/metadata.xml
index 63e4458e8c25..a8f33ec36a9d 100644
--- a/dev-python/sphinxcontrib-asyncio/metadata.xml
+++ b/dev-python/sphinxcontrib-asyncio/metadata.xml
@@ -4,6 +4,7 @@
<maintainer type="project">
<email>python@gentoo.org</email>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">aio-libs/sphinxcontrib-asyncio</remote-id>
<remote-id type="pypi">sphinxcontrib-asyncio</remote-id>
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
index 1fd703331894..7b80ce7fde63 100644
--- a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="sphinx extension to support coroutines in markup"
@@ -13,17 +13,18 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
-python_compile_all() {
- use doc && emake -C docs html
+distutils_enable_sphinx docs
+
+src_prepare() {
+ # fix for sphinx >= 4.0
+ sed -e 's/PyModulelevel/PyFunction/g' \
+ -e 's/PyClassmember/PyClassMethod/g' \
+ -i sphinxcontrib/asyncio.py || die
+ default
}
python_install() {
@@ -32,7 +33,6 @@ python_install() {
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
# clean up pth files bug #623852
find "${ED}" -name '*.pth' -delete || die