summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-devhelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-21 00:15:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-21 00:15:53 +0000
commitdb653baf275126269bb89ea0d2bdb8e50497a94c (patch)
tree9d1ee94cfa7312384acd366d3dd8f629660b3f18 /dev-python/sphinxcontrib-devhelp
parent1534d50aaf24272ec425fa439389ef7e1f7bf174 (diff)
gentoo auto-resync : 21:02:2025 - 00:15:53
Diffstat (limited to 'dev-python/sphinxcontrib-devhelp')
-rw-r--r--dev-python/sphinxcontrib-devhelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-2.0.0-r1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-devhelp/Manifest b/dev-python/sphinxcontrib-devhelp/Manifest
index 594a08d23c21..414dcd4ece89 100644
--- a/dev-python/sphinxcontrib-devhelp/Manifest
+++ b/dev-python/sphinxcontrib-devhelp/Manifest
@@ -1,3 +1,4 @@
DIST sphinxcontrib_devhelp-2.0.0.tar.gz 12967 BLAKE2B b99418693db6b1d3466b18025c6d2be73d4a567419454905642ccc805f34292df1bb6b69a8f39b6a48ed3335fc61a59d9e5a08e65909885b9facbcc90937fcc5 SHA512 72d0bef99f46422160e54053e2594f04a90cd5bc0d8a7ce51259e013472fb9b5102dd87a2807771455d04ceceea94df5fd77cea08e922688f70b62630087083e
+EBUILD sphinxcontrib-devhelp-2.0.0-r1.ebuild 714 BLAKE2B fa0bc94ff51d5f09b240034477fbc9adb4de3f50482694ad6cc42bf57a651f878dc8e24beb03a3c0974122d1e5793d53187df0c1ca21f9156ed295b194909ac0 SHA512 9126e90df5b139b4be47d7dda8b66159b56aeccc509c46bede39e63035c54d170c52d9e8e49317def9aa34cd3395b6502cad35d5c1cdf4b43a0bf20bd4e5a6eb
EBUILD sphinxcontrib-devhelp-2.0.0.ebuild 720 BLAKE2B 5291cb93dbe870f5a07d750adcf1a2949e01a662fedc10cee72da276542cefcf369c0f37863bdae60db44d47cc7954de0312e1f0585663dc8c49bce470e1b4af SHA512 702fc2cdd88596352b499c42e59a5aa6eb3273130772451317ba04c384c76bb7dcef148a051b4e9077fbeb81a3f1fcc82417d99e04ca8c34304ff69ff37943ef
MISC metadata.xml 421 BLAKE2B 0149d4fd64eb705d8731df8aab1a95f29797e68db4cee2dc31b9c1e1cda44223d966e0ffbd1e5ec1b83952f18c3d9965d4d1d7df51fcf88d8549e30572b0ab91 SHA512 b4051429218926b1a0ea4cf02f48a1ed3014245baa2fc4704d4fff116234fa2a83cd8c229377faa8e2f613445df1391d292c77482c59bc5441289e7d92bb8dc7
diff --git a/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-2.0.0-r1.ebuild b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..218eb58e7657
--- /dev/null
+++ b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-2.0.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{11..13} pypy3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs Devhelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-devhelp/
+ https://pypi.org/project/sphinxcontrib-devhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest