summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-documentedlist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-19 17:57:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-19 17:57:29 +0100
commitd473a706836012853193afc7000922601e4ada61 (patch)
tree01c43bd6b2121d90bc97ead47dd7654d9402ea1d /dev-python/sphinxcontrib-documentedlist
parent420eeee727d39d869d864caddb04a80dafda7160 (diff)
gentoo resync : 19.10.2017
Diffstat (limited to 'dev-python/sphinxcontrib-documentedlist')
-rw-r--r--dev-python/sphinxcontrib-documentedlist/Manifest3
-rw-r--r--dev-python/sphinxcontrib-documentedlist/metadata.xml15
-rw-r--r--dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild31
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-documentedlist/Manifest b/dev-python/sphinxcontrib-documentedlist/Manifest
new file mode 100644
index 000000000000..1424ffae22f2
--- /dev/null
+++ b/dev-python/sphinxcontrib-documentedlist/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-documentedlist-0.6.tar.gz 4983 SHA256 0ca2009a577b3e3b2a5dabef8c0e2d5067be8ffda84f893ca356a8a9784fc21a SHA512 9d7f14400b2a3e9b96f01ac003f70c0f7112d9286b2a978495f3089fe94137b034835bd91944e5709fb22553c30c9c324558c9a38ae82b932e1f2ba7f6927dd9 WHIRLPOOL d661d2016a777aea218ed352f64dae706edc326bae1d5fdd47a97368d394bfa883f45765f5ac05aed232f212703348ef5cbe3c908c2dbf461803a328acf7de1c
+EBUILD sphinxcontrib-documentedlist-0.6.ebuild 728 SHA256 e64f65d768705b6e2da35bfc94ac0fadf09b8ccd2aeaaf9b90f667060a6a939f SHA512 fc9be3eb11125a03c3bdcf99ab094933e4650aadb030b2238e4cdbde71c3fdc637e90105675aeb4377e9936bdcc58eaf720ac660633fb42d78543c63f3d32d82 WHIRLPOOL 65726d59272deed9aae28cf905653855f24b2ca7d57daff2704ff570ff68ecf01814729f64b5f7241a72f665f76264e8703f866e792256567bdef9a179738411
+MISC metadata.xml 471 SHA256 4da2a06e647607f5334aaf5eab1d9c8a3fa187e0e614384c20dedc877780eedf SHA512 592f9dc8e3283c317def62b115c5d1da7fd456cba130922ebabb63b8c07d29e929f79491f23fa196b385858740147ecc0683ef0ddc81e3bb90d61eb03541b75b WHIRLPOOL 6cf7ec822ad73395621e18972d3d7237d3151ea07030d00923eb003fc543d22f795e867ab195c8bc495cfcb25dd509ce6eea9260f98cc1e1f1f6ee79ced9b9be
diff --git a/dev-python/sphinxcontrib-documentedlist/metadata.xml b/dev-python/sphinxcontrib-documentedlist/metadata.xml
new file mode 100644
index 000000000000..02a776fca8b7
--- /dev/null
+++ b/dev-python/sphinxcontrib-documentedlist/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fkmclane@gmail.com</email>
+ <name>Foster McLane</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-documentedlist</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild b/dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild
new file mode 100644
index 000000000000..b55b8017c3e2
--- /dev/null
+++ b/dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to convert a Python list into a generated table"
+HOMEPAGE="https://github.com/chintal/sphinxcontrib-documentedlist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}