summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-doxylink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-01 19:28:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-01 19:28:40 +0000
commitd628c1f8493d09e3deb5d19971cd21691d8758e4 (patch)
tree7afecb9f9148ecf631ac2093143278e041cc5acd /dev-python/sphinxcontrib-doxylink
parent4b1be5ef874aaeb61a2116048e0c2312e53f8c69 (diff)
gentoo auto-resync : 01:03:2025 - 19:28:40
Diffstat (limited to 'dev-python/sphinxcontrib-doxylink')
-rw-r--r--dev-python/sphinxcontrib-doxylink/Manifest2
-rw-r--r--dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.13.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-doxylink/Manifest b/dev-python/sphinxcontrib-doxylink/Manifest
index 503951f5a3e5..a3665c2ea355 100644
--- a/dev-python/sphinxcontrib-doxylink/Manifest
+++ b/dev-python/sphinxcontrib-doxylink/Manifest
@@ -1,5 +1,7 @@
DIST sphinxcontrib-doxylink-1.12.3.gh.tar.gz 23632 BLAKE2B 4a80366f4beeb9715c69c221a8e5247c28179613b59fb7bdadb1f145b69e4afdc0c2c30affd9647ec9e56e892503a95d018fd97eda014980177282299b81d61f SHA512 d25003dab35c6877bc846552db3e663c660bd5cb6ac6d9077bf04eca32afe0f9559118390c5c884901ce8c5297e97d84f6089428e3173123da6e7869a606a05e
DIST sphinxcontrib-doxylink-1.12.4.gh.tar.gz 24425 BLAKE2B 04c3a9fef624d87b5f9b756dde6bd9a12acfcefb5331ebaa9a97267b0a8389b96676f996bbd8817c0e4096aad693e711527e4981f8a035e70a4abfd26834b53d SHA512 6b1edef1e78635d30fba34abe6f6cfaadf9e941a50c2c13790da848300289938e1f9eafdce5a820e68ff26f2975a14945ee1c43963074343858daa34c16de513
+DIST sphinxcontrib-doxylink-1.13.0.gh.tar.gz 25389 BLAKE2B e834d6cfa5f369f6c32f3ccc527b26d97d51ec3d2bf168a5687ea21b86057ee24804c8e53cf3df1e56076cd43b09cfe5443dc9423eb490d6a32d7f169fd59a37 SHA512 f4df39c5d63bc19ce01b16bb614b3a624f768ea883621167ffda6c724cf8ef296ecfd37179d3f3849f4a953cc9e7d72085507eb8f2313a4dfb992b19c434921f
EBUILD sphinxcontrib-doxylink-1.12.3.ebuild 1092 BLAKE2B 158f444939123b61ea633971bc77d0108ea405becedc099c5d80f2a9fa644bdd982d596f691909afb9995b1682ce2d73cb1903f654d511ec06be18740049716a SHA512 c91b42533af77f6f665319f972c0bb6406af27751720f9554e46006d9e5366b7e033a024480e44d5410e84c4cc543dac5d411a8a0c161adfaccd2074a2c79c35
EBUILD sphinxcontrib-doxylink-1.12.4.ebuild 1094 BLAKE2B f6b4e2be97ddbf22e4b1bdc3fb50af645ca111e8a1557bdca40ee4f79f46bc69752a467e1974b9e07e7651482dc339e62676de9dc4e4a33e67935216ffbaadbe SHA512 2d4ed357ff0eed69ce0987880c776f9c57ec2a067904e0da24e9efc1e12b482a286eae4604f153558990407b5c962278970b8dd423d9b637057b59a0303e1477
+EBUILD sphinxcontrib-doxylink-1.13.0.ebuild 1094 BLAKE2B f6b4e2be97ddbf22e4b1bdc3fb50af645ca111e8a1557bdca40ee4f79f46bc69752a467e1974b9e07e7651482dc339e62676de9dc4e4a33e67935216ffbaadbe SHA512 2d4ed357ff0eed69ce0987880c776f9c57ec2a067904e0da24e9efc1e12b482a286eae4604f153558990407b5c962278970b8dd423d9b637057b59a0303e1477
MISC metadata.xml 620 BLAKE2B e76f6c16f0f8280d0d7a99975a0dad33a76f93a634d99114df5eacf047e434c7356cb501c4021cdee1b17c3e7dd00e7ce4720d70c1ddddcf561c4e622b528549 SHA512 89afb14c72168f5a919347726c1445a205d5839925ead8b3969cc84f062caca0a666cc141f541c21d642f95c3c40fdfe677e3f1cce78aa1a5f6445e140ae7978
diff --git a/dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.13.0.ebuild b/dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.13.0.ebuild
new file mode 100644
index 000000000000..f06617c456e7
--- /dev/null
+++ b/dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.13.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension to link to external Doxygen API documentation"
+HOMEPAGE="
+ https://pypi.org/project/sphinxcontrib-doxylink/
+ https://pythonhosted.org/sphinxcontrib-doxylink/
+ https://github.com/sphinx-contrib/doxylink/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/doxylink/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/doxylink-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/sphinx-1.6[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ app-text/doxygen
+ >=dev-python/testfixtures-6.18.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ cd "${T}" || die
+ epytest "${S}"/tests
+}