summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-htmlhelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-21 12:30:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-21 12:30:10 +0100
commit4968fd889f69d50cfcab1ffa12e56bdf476d9939 (patch)
treeb7b79ef2705cb29f73763bce76d98b1a8ceb667d /dev-python/sphinxcontrib-htmlhelp
parentd3ae3ea75073c53ed5f3a4418e76383436bb0f58 (diff)
gentoo auto-resync : 21:07:2024 - 12:30:10
Diffstat (limited to 'dev-python/sphinxcontrib-htmlhelp')
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.6.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/Manifest b/dev-python/sphinxcontrib-htmlhelp/Manifest
index 54fac6995ce7..15bca69ab0f9 100644
--- a/dev-python/sphinxcontrib-htmlhelp/Manifest
+++ b/dev-python/sphinxcontrib-htmlhelp/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib_htmlhelp-2.0.5.tar.gz 21925 BLAKE2B ba023e53c14b5427b09a9608cfc45ccdf932d4c27cce40932088fadb127ebfe50d7b2639513589469facf108fdc748e0f07195766e6e4bc67d26c50d00a2bf75 SHA512 537ef6a1a32863728a6324fcd50f9374e4f488ed7ed112f9f0ceb9e4488637f502280dda21835e8d63c6b6297d2a3db3032c3f307dce5948b516f293d07b9711
+DIST sphinxcontrib_htmlhelp-2.0.6.tar.gz 21957 BLAKE2B 44b03832d8b89978062028be32a1253f2d5f2134b83f7e95fc685ab669ae3b4131dbad452e49d84cef56993a701f1cc1fbf1f50583fdc114eed7a05ad261c5ac SHA512 842194261315b35c470dee36ea7945b73dd08338f2b86d542b3a21d1cb900a2fbe0ba8ec2412589b4c8993b71d88b0e4fcfb0e3316db61c8ba2989811d3e073e
EBUILD sphinxcontrib-htmlhelp-2.0.5.ebuild 759 BLAKE2B d6a931be7d09ce83d23f545e779887fc70705aa6920dc0003fc0da4ed48d8e627302d17a36b9ef82c5d0633cebb919c3fcb796d2361dc94da9e52b795ab2b1e6 SHA512 c020f704eb46156a9e77e56a1562b99216bd3a33ace820c2edebf492081a41dd9f26ad5baf4224cb8304efea94b62c28212138f397c6393e505e60649d87f315
+EBUILD sphinxcontrib-htmlhelp-2.0.6.ebuild 767 BLAKE2B 81fb51de2156d11bb7e4c10c6c88866d2d3b34f02d6bcbe1aad8cdae8bbb47506da51e97f738fa551cf74751e8dd2ed384f5a685a94218b3573eeaeca0fee992 SHA512 ad0a2be2009c4b3e7201217e2b0844536a4319fe4d703e99f589d532a18070bded58096118b4b70b44344ad996419cc5a529788daa47135653c106cef85de676
MISC metadata.xml 423 BLAKE2B 49685b4a452f9f05a9f385c7c1913c282bd0714e1c92e42347960bdfa29ae01ed4eba7f43e3d1b7241d6bca4ddf4f8d3e0a1d0820a8af5edb7caca934908ecdf SHA512 8f497fb7ea0724be086c8a564481cf4d46ecf048791f76ed5494a7b0c0f46bf5eaf46875f0695b9add2914430c78427a5a77113a5f379052922217b415bfdb50
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.6.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.6.ebuild
new file mode 100644
index 000000000000..85c62da13499
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-htmlhelp/
+ https://pypi.org/project/sphinxcontrib-htmlhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest