summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-htmlhelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/sphinxcontrib-htmlhelp
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/sphinxcontrib-htmlhelp')
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/Manifest3
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/metadata.xml11
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.1.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/Manifest b/dev-python/sphinxcontrib-htmlhelp/Manifest
new file mode 100644
index 000000000000..0bf59ce5ad03
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-htmlhelp-1.0.1.tar.gz 20448 BLAKE2B c7e8cc306f196719b60f4ae8aa678a09d18f7986529b71e4631b99a14d4631b00d9f59766f4d96eea1f16e26adc3e0998295b766886def705be57adf0016ee2d SHA512 a364a490e5043e767a8b498b5b621f3f3c64bf15f65847097489d3d2ba8620adea2045024d5189a68d97af6f68161f714f09a712cdd9fc6d06524ea818cf2e1a
+EBUILD sphinxcontrib-htmlhelp-1.0.1.ebuild 757 BLAKE2B 46a80ba87c9d62131bc8736d1abaa53799918f8504b6b80b1cdd8fb5cdf62027274b17b46583c201fdb6e4ada727696f9ee9b465f7acce8cbdcecea19db0d3c9 SHA512 5f710273958986fe98d840cb794fedee12b772083ff4c3d21d0b0a66d521946fe02980842f7e5290f098c79b2078a604ca201fc18c335364b231da687af400eb
+MISC metadata.xml 325 BLAKE2B 86b320327210716251580bcde7ca53cece58e22f07973de023d09bb7a6b68cc4e4c4cace4c9b8ba73f15482332e3b94e38650468fe790e8f6c123c77b9f2ad48 SHA512 700c19351b017fed0536e0e57728b410052b2c34bf06912aedc754e4f931614f3f4b31a10bb67381134c9bd5f61f9af23f204641e8e531ec0ff9a6c1cf9eb41f
diff --git a/dev-python/sphinxcontrib-htmlhelp/metadata.xml b/dev-python/sphinxcontrib-htmlhelp/metadata.xml
new file mode 100644
index 000000000000..0cca313393e1
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-htmlhelp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.1.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.1.ebuild
new file mode 100644
index 000000000000..ebec7800e64c
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="http://www.sphinx-doc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND=""
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}