summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-htmlhelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/sphinxcontrib-htmlhelp
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/sphinxcontrib-htmlhelp')
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/Manifest b/dev-python/sphinxcontrib-htmlhelp/Manifest
index af3d18eafccf..6b6eeefd4e54 100644
--- a/dev-python/sphinxcontrib-htmlhelp/Manifest
+++ b/dev-python/sphinxcontrib-htmlhelp/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-htmlhelp-1.0.3.tar.gz 24248 BLAKE2B eeb7edd0bce99621ce6fa3a2bb9ba90a619af18403c8b4b0148a7d20fd3847f418f35bb1bb413531c0799b5b98be7b45aca51aa5c8120d9c997abb86ab0b0f01 SHA512 f37542c5789340bb26c41b84512e08998e4ef45ff2eb0fdb0e10f585cff27a145d5821b8eb3766d009e2b5a38c3d7efb127ab898982e1b6fd1d4ff7e26907db4
+DIST sphinxcontrib-htmlhelp-2.0.0.tar.gz 28144 BLAKE2B 09b0d9bcec57140278c4476fa0bbc40d359fc167d8ea891a1585fbdeafe6eb0b52442dbbc8d1d5b6edb3953b04fc29a71f6f74e58a281ebb0d79e5a30cb02749 SHA512 6ed673966615f3e818e00de4b7e59c27f0a0d7b494294f804540777c580480870c36002c08d8ad626b7b41a676fe40edc0b0b5ffc6ad8080f38f59c24e157636
EBUILD sphinxcontrib-htmlhelp-1.0.3.ebuild 880 BLAKE2B dcdf06525954627e866d02f8e46df726d52794334da88c5a4b86768cfe32cb1459e9e15fb041f6077d6770b011ceb7ecffbd9b8b6debcd06f630317fa836d785 SHA512 fde00e62f1fe8244e6b0883344b0ec2cd01a0aa2aca6229bc0d20eeed32d79ecbd1e008774780edac645cf64bfc2d019c792d23a206a832c3694fd9d8516de40
+EBUILD sphinxcontrib-htmlhelp-2.0.0.ebuild 890 BLAKE2B 597c07091265c29ad4bc16e1fd83e0af86afd003311abc3aae87c3b8f1380ff1fb4cd70d37af02c5a43cd2f3c6bcd5e86088ff9e2afffb0636d75b118fc8e662 SHA512 9341158c2c9b5da1a41ef0e0297cf78bf6399f34f97c66bbab24781390fd4809e0eff888960f974119e369b3e8f0498092c7f9d2e49846e6394264190695ebc6
MISC metadata.xml 398 BLAKE2B 84cee02bfaa0420c3bee0d1324270b84678a306904ecf3b30237d4ad7ceefffd97528109552e00d3aa1b2ad4eb6d9cd0e10341fb122c7a1830031870c1919dd8 SHA512 63c17014837ebf2e8bfce709fdfcd9de27c0071aa527a790c6e1e66c1246ae6e4635e8c30b7b486c9bdc727d7e044bfc30d848058bfb4eafe3eb8c32478a5b69
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.0.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.0.ebuild
new file mode 100644
index 000000000000..d48fd742660c
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-htmlhelp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}