summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-jquery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/sphinxcontrib-jquery
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/sphinxcontrib-jquery')
-rw-r--r--dev-python/sphinxcontrib-jquery/Manifest3
-rw-r--r--dev-python/sphinxcontrib-jquery/metadata.xml13
-rw-r--r--dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild34
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-jquery/Manifest b/dev-python/sphinxcontrib-jquery/Manifest
new file mode 100644
index 000000000000..b41579533cc6
--- /dev/null
+++ b/dev-python/sphinxcontrib-jquery/Manifest
@@ -0,0 +1,3 @@
+DIST jquery-3.0.0.gh.tar.gz 121750 BLAKE2B 5b160fa1434b111683824442a0ecb0da230dba7f29161495859845282e1b6471faa256be6fffc2d34c6fc97e4e188bb1247284613bf65bf322fcb77463b6cf83 SHA512 a681f42734f2925b597f8d90c7b90a3f6df9549d1c97195799670542c5eabdc4d4d4aecfef29f56bd74ffad18ab179cc47f27b8395c11388259473690601901a
+EBUILD sphinxcontrib-jquery-3.0.0.ebuild 706 BLAKE2B 73ea6ed45d49d38106905e46e6221cbc0edc1c74741d83529c925fa5eaa6ab2b86425889d3edd670a974a25673747bb3b42de162aa346330b5005a2ef5bcb7d9 SHA512 28907abfcfafd6d5a85c9927de2a3d7ea4f23699b6e6ed49764d5625fcf9d18008356110075f6076d1bc5a6e2a87ada0c7723b4be56d2743691e09fa1c250907
+MISC metadata.xml 409 BLAKE2B 8710eef90c8bbe37c7e21c242608c637c26bcd7953274f5ed958cb4faa9102e03d19d57212e5bce9c59f504cf8820f1c5149569b3d766049ecccf6a758a375c9 SHA512 5fbc9e23858c95f46baf32101072b60f081243a801dcf4bbb03708cadaa4516dbfccdd81c7a5a5a17e9c78233efdaf28dcd70c0e00470f9dfa8691a0405fbae8
diff --git a/dev-python/sphinxcontrib-jquery/metadata.xml b/dev-python/sphinxcontrib-jquery/metadata.xml
new file mode 100644
index 000000000000..68f6d58c7f2f
--- /dev/null
+++ b/dev-python/sphinxcontrib-jquery/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">sphinx-contrib/jquery</remote-id>
+ <remote-id type="pypi">sphinxcontrib.jquery</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild b/dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild
new file mode 100644
index 000000000000..37baddac2ae2
--- /dev/null
+++ b/dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=jquery-${PV}
+DESCRIPTION="Extension to include jQuery on newer Sphinx releases"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/jquery/
+ https://pypi.org/project/sphinxcontrib.jquery/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/jquery/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+# MIT for jQuery
+LICENSE="0BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv"
+
+BDEPEND="
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest