summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-jsmath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-21 00:15:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-21 00:15:53 +0000
commitdb653baf275126269bb89ea0d2bdb8e50497a94c (patch)
tree9d1ee94cfa7312384acd366d3dd8f629660b3f18 /dev-python/sphinxcontrib-jsmath
parent1534d50aaf24272ec425fa439389ef7e1f7bf174 (diff)
gentoo auto-resync : 21:02:2025 - 00:15:53
Diffstat (limited to 'dev-python/sphinxcontrib-jsmath')
-rw-r--r--dev-python/sphinxcontrib-jsmath/Manifest1
-rw-r--r--dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-jsmath/Manifest b/dev-python/sphinxcontrib-jsmath/Manifest
index 6529aff895fd..f283253d04e2 100644
--- a/dev-python/sphinxcontrib-jsmath/Manifest
+++ b/dev-python/sphinxcontrib-jsmath/Manifest
@@ -1,3 +1,4 @@
DIST sphinxcontrib-jsmath-1.0.1.tar.gz 5787 BLAKE2B 055ff298e11678d7d30975e4bef509ece0128be30ca0c5fd2be1323c2eb4fe92f861826ea5ddfcbd2d3e3a80535b374d2b1a13446c2604f3e448d5a8982b9881 SHA512 c1e6488f5c0ca4567c27ec7c597c9db321ac32ce354c4ad62fea534b2ae1c0acb183a921f46216bbc3891f14acfaac05ddf324b8fdaf99828df07bc91aa7e5c7
EBUILD sphinxcontrib-jsmath-1.0.1-r3.ebuild 1208 BLAKE2B a5817308e00a6051a81bfe2c643648255e082228e596714b8c41e07a323f4791ec9357b4232804970c5f167d86b65a0d7d6b737346d79835d76afab05f38d650 SHA512 23b435f8f09e49ceae8e980323b82270470f79045abea028717f6e0ec2e6e33df9015d31787c0237285b7786fe54f1772d43f6efcf0cb221ec474b3ab62fb91a
+EBUILD sphinxcontrib-jsmath-1.0.1-r4.ebuild 1202 BLAKE2B adbbdee09afd2397457a620faad129781f9eae7ad733ce67327ae5fda0fed1d26de7dcacca480015154483ab9ae9b5871ea667f157ab63824621b0fb52bb2306 SHA512 ff5b6ec6a1c80fbc77562c1b04348217707e36c4e66812a79261beb767cc7d8946254de4407392b37b6531d65cb0a5a76007cddbe0888d8a6e720e079fda1dae
MISC metadata.xml 419 BLAKE2B 7b22df905fbf04eb026a37a8bcf2512508558a000793354a80fd7cb06bcacbb032291c24b1edd40cf884248bb761f9e9638b5ff55c6d59aa406777dfe2361214 SHA512 3fec9aaa8e570dfb8c4559dee30b71bdc479d5ac18431fcf85d1fd415adce54b8f2783ced3a5392a08ed083570622e500bf489c7b168f65a395248aa2c235629
diff --git a/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r4.ebuild b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r4.ebuild
new file mode 100644
index 000000000000..ce3ddefe4de5
--- /dev/null
+++ b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{11..13} pypy3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which renders display math in HTML via JavaScript"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-jsmath/
+ https://pypi.org/project/sphinxcontrib-jsmath/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # This is already fixed in upstream, remove it on next version bump,
+ # see https://github.com/sphinx-doc/sphinxcontrib-jsmath/pull/10
+ sed -i 's/.text()/.read_text()/' tests/test_jsmath.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ cd "${T}" || die
+ epytest "${S}"/tests
+}