summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-qthelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/sphinxcontrib-qthelp
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/sphinxcontrib-qthelp')
-rw-r--r--dev-python/sphinxcontrib-qthelp/Manifest2
-rw-r--r--dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-2.0.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-qthelp/Manifest b/dev-python/sphinxcontrib-qthelp/Manifest
index 645f11079e6f..c9503a4bb2fd 100644
--- a/dev-python/sphinxcontrib-qthelp/Manifest
+++ b/dev-python/sphinxcontrib-qthelp/Manifest
@@ -1,5 +1,7 @@
DIST sphinxcontrib_qthelp-1.0.7.tar.gz 16685 BLAKE2B dbe4518134f31f9283a1de4a9f7c1b1fd59e3c639923dd5a84fe1c60323f8c0fbf31942ab51724241bf8865b78c5c83bc7c2187d7209b1c55027245cae2bd271 SHA512 fa11be5f663a0784a59ee18deaa8d497eeb4d5311fd86f75d48f40b70d8c0c868bd8625a001da274379d2b3412447abd810cb44af42f8a252cbcc31c400884c9
DIST sphinxcontrib_qthelp-1.0.8.tar.gz 16778 BLAKE2B 71c0639f526e3a83bb5c47706e0073234a40691d22337cb41920f612fdd2798731b6d84cde2744e24e545c9d23559a48cc94ecdf49f887404370c3ef3f698756 SHA512 d3bde9e5e8ace4f58fc76bea22fdd7740a503f46a671f52f836039cd85f62733187b87395669bb2566de451c4de253725316ff97ca3c910b8dd31149c3c80331
+DIST sphinxcontrib_qthelp-2.0.0.tar.gz 17165 BLAKE2B 568d59a1ec6d46bf0974bda0112396ed0e73576bef691214ecd61e551030a55e719d485149aaa1ca353243155d48f8e0f1218a67ddeb73f3fc83c4b99655e52d SHA512 d551559a6f0fddf61ea24ce067e28a6bb8a61dda1f62e3a2531e43c8ec8059eb819b6a37f912425832c1b0f8dc4b830614240c38abca8a04b31ebb0ded59ec4d
EBUILD sphinxcontrib-qthelp-1.0.7.ebuild 759 BLAKE2B 8c4b3c8e3f70e81412b12f89e132546fdd99c8139c7b5ba3975c3cae86cb2475423d36b17bda36b181a954889a50bc9e1ca8b1e5f96691dc78e88b450540c60d SHA512 c1aa152279f151bd88d1a7a3868b00aeae6e03c93325740b5f25e4545a5ffdfcfdb3c386289fdca3e3142b9e8855072871e704380acd3527b6c1324408812413
EBUILD sphinxcontrib-qthelp-1.0.8.ebuild 775 BLAKE2B 8833fd30fa0193dae8a7dcae66d20bcdf09477c542d70f9d2ca324cf44c9ffe289ad959e9c3984d5783ff28ac33e1cf792576d2d586f227d8c93a7446e0a7ea8 SHA512 c9ab5e4a239d5802b78ab0fd0e6e6998f147df73c10e3610f8d29ca29ee18134134d8e2b625d59c417df72b6e8a2297df406cf8b0e8a3a2c46dc148db0214377
+EBUILD sphinxcontrib-qthelp-2.0.0.ebuild 775 BLAKE2B 8833fd30fa0193dae8a7dcae66d20bcdf09477c542d70f9d2ca324cf44c9ffe289ad959e9c3984d5783ff28ac33e1cf792576d2d586f227d8c93a7446e0a7ea8 SHA512 c9ab5e4a239d5802b78ab0fd0e6e6998f147df73c10e3610f8d29ca29ee18134134d8e2b625d59c417df72b6e8a2297df406cf8b0e8a3a2c46dc148db0214377
MISC metadata.xml 419 BLAKE2B 5a559b50428f6425568dfbae01bce3ada0905cbea24542e75122f1f3fce9e04cec6861f4d662515c7efa8c15a5b2347a83af5a2ea38326c069f9253436e7199e SHA512 559911ed37cd63368b2783fd6d65aa9b5fecc7b58422978f9d86b32eb8f50275f6b52a910ea4c73ef2ef3d081373862eff8a8e0e4098bd83c6b1cf4f06cd1af0
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-2.0.0.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-2.0.0.ebuild
new file mode 100644
index 000000000000..b9254b35efa7
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs QtHelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-qthelp/
+ https://pypi.org/project/sphinxcontrib-qthelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ ${PDEPEND}
+ )
+"
+
+distutils_enable_tests pytest