summaryrefslogtreecommitdiff
path: root/dev-python/spotipy/spotipy-2.23.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-07 23:31:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-07 23:31:01 +0100
commit11e4049d80ff5ce2aa21c2bb5dab36897e5359e9 (patch)
tree8a9bf6a29e45cb7a9c9cdc39be9dcda18917cd1a /dev-python/spotipy/spotipy-2.23.0.ebuild
parentdebb2c431b40a6b4750a39956cc5fcfa5a4a6476 (diff)
gentoo auto-resync : 07:04:2023 - 23:31:01
Diffstat (limited to 'dev-python/spotipy/spotipy-2.23.0.ebuild')
-rw-r--r--dev-python/spotipy/spotipy-2.23.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/spotipy/spotipy-2.23.0.ebuild b/dev-python/spotipy/spotipy-2.23.0.ebuild
new file mode 100644
index 000000000000..a52000b0bcbc
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.23.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight Python library for the Spotify Web API"
+HOMEPAGE="
+ https://spotipy.readthedocs.io/
+ https://github.com/spotipy-dev/spotipy/
+ https://pypi.org/project/spotipy/
+"
+SRC_URI="
+ https://github.com/spotipy-dev/spotipy/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/redis[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/unit/test_oauth.py::TestSpotifyClientCredentials::test_spotify_client_credentials_get_access_token
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}