summaryrefslogtreecommitdiff
path: root/dev-python/spotipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/spotipy
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest2
-rw-r--r--dev-python/spotipy/spotipy-2.20.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index 1179d9026743..ab94dcbf6073 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1,3 +1,5 @@
DIST spotipy-2.19.0.tar.gz 102703 BLAKE2B bc132edb972236b43097c0bbc9d86932a3305d8bd3807e44e20767b123455950b8e01060efd83c87b3a162e329f5c48614205f131686af7f9312a44894a7f1e7 SHA512 fbaecd1a2cab3ef458d30de46cb89462021dfc3cfc85516d8bfe509af016a0b19af2f8de4f5cae36188b1ce1f5718c75edff0e71af2a87f4d720ee99d4541a6a
+DIST spotipy-2.20.0.tar.gz 103437 BLAKE2B 78b026b9de04b0115c5621345e4f4c0ee47a51980221c77da8754c54fc8c321a1826983ceb9bcf9c415690906f3b3ea4657243e6b5d351d3edb48084baeca292 SHA512 8b5d0704fa84974ea0728dda0fe89d021b7b1550b464026d2b087671102745c7edcab116246399dd97de42d9c0cc7411295297c328b301712b6536aa6a3cd6fd
EBUILD spotipy-2.19.0.ebuild 1142 BLAKE2B e5758cedfe1043cdd44513808189a9414f51779f213488bf8fd10f047caff435329a1fb4f1e51c731d63e3cacf817c7f2268205cda6d1a46eff49472dcaf00fb SHA512 060ac664853b219996e5fa75f82601c07bdcbf25c657d6a22c17cba3c38c740caa0d5eda4513b336e69c82d4f22209982dcfe37ce8836a416f55968c6409c7d9
+EBUILD spotipy-2.20.0.ebuild 1181 BLAKE2B a024f14e89eb0a9d5afeb94548a28cb97db5bc85592c7bff6e72e257c74732efa8d304276b39ab1b274ffdaada00252b17933c3bfab6ec7764aae3ea0da18f47 SHA512 89ac69abc71a80de8951768e14a65a812b3fc513e910fa5d305645b169241372dad1efeaff60022d8168465ed8343186f9ac1db62c6dacf3c1c319346ceb400d
MISC metadata.xml 448 BLAKE2B 2307d0b3ca490bcd41c1bf6f6c5a9b12ec0325781125bc68bb17ffb8408873243a9ce224c9405e5d998d1158376eefc211b0cb2575b8ef7dfdaf018d1dc58eba SHA512 17a5a5b1829478029810b46d448d03a74466ae2dc68bb83f295e71cf26c3b5c68a9f5c255529d7d19681986c8ed9f2386c818c73d47f94e85201123cf3ba6243
diff --git a/dev-python/spotipy/spotipy-2.20.0.ebuild b/dev-python/spotipy/spotipy-2.20.0.ebuild
new file mode 100644
index 000000000000..3409dd977e02
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.20.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A light weight Python library for the Spotify Web API"
+HOMEPAGE="https://spotipy.readthedocs.io"
+SRC_URI="https://github.com/plamere/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Requires user credentials
+ rm tests/integration/test_user_endpoints.py || die
+
+ # Requires a spotify client ID
+ rm tests/integration/test_non_user_endpoints.py || die
+
+ # Needs internet access
+ sed -i -e 's:test_spotify_client_credentials_get_access_token:_&:' \
+ tests/unit/test_oauth.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}