summaryrefslogtreecommitdiff
path: root/dev-python/spur
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/spur
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/spur')
-rw-r--r--dev-python/spur/Manifest3
-rw-r--r--dev-python/spur/metadata.xml7
-rw-r--r--dev-python/spur/spur-0.3.21.ebuild36
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/spur/Manifest b/dev-python/spur/Manifest
new file mode 100644
index 000000000000..b20ae28cfc87
--- /dev/null
+++ b/dev-python/spur/Manifest
@@ -0,0 +1,3 @@
+DIST spur.py-0.3.21.gh.tar.gz 17666 BLAKE2B 0628417e6b5f4c744041693445113a59daac4f89776bc39849a2e1fab21826f3c6783bf72bf528a262f05df08d0680044e69f119c367f29ca4d6f0df554fa49d SHA512 7cd49690b989952707629fad5682201dc7f00865d8120da9e84eb9046e7a8fe7b7183785b4c2eac996d2743025cc09508b0ceb7b762b7bddb5447ecbc42d00a4
+EBUILD spur-0.3.21.ebuild 1114 BLAKE2B d88073e0e89b74c513f40fc7dc6a046e2cec66f207185b84a64e0107eb2bc848f447d6f65f8d9adc245330fb62dac8ef68af4f0396a4795392add9baf05ad116 SHA512 ac720f0560f6d15052725a4cf95bb072b9fc138216f1be4e4055a7cd650c52b90a257d6ec6d514315b1c5d1b998ede433eba30f33c57a8bb2c590a1023623d03
+MISC metadata.xml 218 BLAKE2B 086fdcf7b63ca7bd6c58e861d717bb375e1cd372eff26d5d2eeeb176d8c5e6f10e653562abafb50eae7d7508f8e3d421b87e6a749acd0490308672828d0da697 SHA512 4558fee4c51117e21b1f42ca3edbdf1195ed297db798d6bfa0e5fbb7019654a187422b0abde7af5d800caffed66d1e55e4280e8be602bad591424d9776c46781
diff --git a/dev-python/spur/metadata.xml b/dev-python/spur/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/spur/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/spur/spur-0.3.21.ebuild b/dev-python/spur/spur-0.3.21.ebuild
new file mode 100644
index 000000000000..d5660abfffe1
--- /dev/null
+++ b/dev-python/spur/spur-0.3.21.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+MY_P=spur.py-${PV}
+DESCRIPTION="Run commands locally or over SSH using the same interface"
+HOMEPAGE="https://github.com/mwilliamson/spur.py"
+SRC_URI="
+ https://github.com/mwilliamson/spur.py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # TODO: set up a local SSH server?
+ rm tests/{ssh_tests,testing}.py || die
+
+ # does random guesswork on top of exceptions that stopped working
+ # in py3.8; this only causes a different exception to be raised
+ # https://github.com/mwilliamson/spur.py/issues/85
+ sed -e 's:spawning_command_that_uses_path_env_variable_asks_if_command_is_installed:_&:' \
+ -e 's:spawning_non_existent_command_raises_specific_no_such_command_exception:_&:' \
+ -e 's:using_non_existent_command_and_correct_cwd_raises_no_such_command_exception:_&:' \
+ -i tests/process_test_set.py || die
+
+ distutils-r1_src_prepare
+}