summaryrefslogtreecommitdiff
path: root/dev-python/spyder-line-profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-04 12:28:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-04 12:28:34 +0100
commit518b45bffd19d0b75715f338985f96c459f9d129 (patch)
tree948dfe5d479374fd6b85fe72ff2570e8a4af47ff /dev-python/spyder-line-profiler
parent3f559ef486314f9b3b48d48eb303d6be68463af9 (diff)
gentoo auto-resync : 04:09:2024 - 12:28:34
Diffstat (limited to 'dev-python/spyder-line-profiler')
-rw-r--r--dev-python/spyder-line-profiler/Manifest2
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.4.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/spyder-line-profiler/Manifest b/dev-python/spyder-line-profiler/Manifest
index c4f7f8478681..693b684ee474 100644
--- a/dev-python/spyder-line-profiler/Manifest
+++ b/dev-python/spyder-line-profiler/Manifest
@@ -1,3 +1,5 @@
DIST spyder-line-profiler-0.3.2.gh.tar.gz 88725 BLAKE2B 9e15a9b88d1b36a39428e7eccafb7a2c3d3609aece2c6e5c2f379c9f9180093863472bd1e071b12bf313e7cb6ccd4993bb407785716cab2dda871a1ebd527d41 SHA512 fb2e86cc640c7cd32567852063845567634e7cec365f7f5f5f3d770316b9adabc0447d3ad8334411fe3894aeb086cde4f14b77fd3483c099296db7df15f0b46b
+DIST spyder-line-profiler-0.4.0.gh.tar.gz 89222 BLAKE2B 7b4b7d2e884c6843c03289fde1351640fa768d1ede3cb7287859968c81a2207864f8039dff68d4bdf5e5d1fbb622d67ed9b5c90efeb615f8eb6bd6ed37cbd1df SHA512 4210a5ce58f11fb6d1453c29c0b363b111e73e01feb58593d9a4b0e31c3ae8d158a4ae052e633f23ac4b78cb116b68610a2b38e7d686d8cc6ec183723f91ffe1
EBUILD spyder-line-profiler-0.3.2.ebuild 886 BLAKE2B 1bc077539dc4da780d908ae65f584e9fe2e966b7dfae513a00c31fdf9b74c9d29cda652af253aca152bba4a27930e7d60ed026a927ba40ebb5ae289e83ee2a86 SHA512 d8dfe7d92d7509912100eb43601ab304518cdae1c8f9ef0ca2b74c97388bbbd31a1a99995592e93ee12a21ade69f4431d986b06dbb17fe02092f48b912155b3b
+EBUILD spyder-line-profiler-0.4.0.ebuild 871 BLAKE2B d2efc1f259717858696caf174f1aceeea490986cd10b22a7599e73f06f271518848bf0d6eaddc295e3a072adb433a24f3135d3511b834f3f5dc55f755f4fb4f5 SHA512 198510f07ff633bbcd773b799797d43ceab800eb1f3567f5446830331998f4b4face906cce5fbb68e040115efad3325ae3c74d615fa6927d7fd8b0cc3eb7cee1
MISC metadata.xml 437 BLAKE2B 254a233cdcef8d6960ba16b23c7d7db791b3291895ea2d6327691565bd9fc25c059727598cfe4893749ce691556c3d7c0edb006c6d7f2f39ca596a838bba16d3 SHA512 df4a0bce4f15301ff686c91e9d921dced3821659cd9a4fcbcc1866114fdbcecccb01452ce53ae75b270a38d38dbf838f2a603fdab6aeae1e709a530584a9c9e8
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.4.0.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.4.0.ebuild
new file mode 100644
index 000000000000..c06691818746
--- /dev/null
+++ b/dev-python/spyder-line-profiler/spyder-line-profiler-0.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="
+ https://github.com/spyder-ide/spyder-line-profiler/
+ https://pypi.org/project/spyder-line-profiler/
+"
+SRC_URI="
+ https://github.com/spyder-ide/spyder-line-profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/line-profiler[${PYTHON_USEDEP}]
+ dev-python/qtawesome[${PYTHON_USEDEP}]
+ >=dev-python/spyder-6[${PYTHON_USEDEP}]
+ <dev-python/spyder-7[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}