summaryrefslogtreecommitdiff
path: root/dev-python/sqlalchemy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-10 06:41:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-10 06:41:31 +0000
commitf9d8ddaae80afb8fa0924cd3f769f9b37dd373e1 (patch)
treed8962e6446d606b8c95329b4b78932a65f928a5f /dev-python/sqlalchemy
parentd94fef9a5708b8e64f363f4a71f0b56caef5efe4 (diff)
gentoo auto-resync : 10:01:2025 - 06:41:30
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/Manifest2
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-2.0.37.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index 2d0c9ddedfbc..d7e2ec5e504f 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,5 +1,7 @@
DIST sqlalchemy-1.4.54.tar.gz 8470350 BLAKE2B 0d97beb4edde38455c03dfc1238655d1cb63aa6e042b941913ec68dca3654de07087ab967f208fda495f048a5068ced70d642c4b8b80ab32e5346fcefa3bf9bc SHA512 e7ea4920d81914d362134a3c6fd4a2dd4fdb75f6ce17358528d568e2b2ac0ee711a71f6beb894e61d6d1e4e5833034ebde651d73a13f873c682f780e1831b427
DIST sqlalchemy-2.0.36.tar.gz 9574485 BLAKE2B 31fb7375041f354b940a5b8beee8886cbb66cb0a4b4dcad8f9bdb9ebfeb673cdc6ce7335d9fa7bbc443e3dafb0337106e0ca0c6a8ccf3df55bde3e6e310dcbc6 SHA512 480fa9893d20806127f6b060726210e32989af92439ff445066aebfc931453eb8c05b5f8497582fcdb897f8e9e70243f092f46e06d7dfe49301ab71ada4eebda
+DIST sqlalchemy-2.0.37.tar.gz 9626249 BLAKE2B 8bcfbaa7d83c09b5c57cd422ac6e0ba759a5fd8ec63af01f32fe35c616811a74a9e19382813b2104a938aa3a19aa4adbe36cb02ad206cf069a8649094d483cde SHA512 ea83a9cc1bcd69424d8f0b6c0f2195ac2c7c77ad92187d9f83e1c0d02fbd0bc8b75973c1849757283434041f073994ed235dc9d520c24f21bd72b4cd20a51a5c
EBUILD sqlalchemy-1.4.54.ebuild 3347 BLAKE2B a4fafd26e964fb7f05755d7ffaa3d815d526b9933b14f63c3ebfea855bd12eafa241d965b87b5d006a6b267dbc7b4ff4719360028a79493e0ce087b290bd5181 SHA512 b828750e35ac00c86e1a546f4818751033d3374257062ee35a3b81be5b08ba4d5408f2d7c05c1ec317687d3a6442979015f8637b4f131d831ca25a4a41199122
EBUILD sqlalchemy-2.0.36.ebuild 3875 BLAKE2B 571c06a100113017e66e701522851bbdb8143f4adccfb9925591e38d8a600dfcab4814123b67c3d5ab58ee828b6d81a0b0d77433fb79fcd912782410c74dda27 SHA512 045dfd73c8986f3c69bee498bfcbd45b749db9aa3aa9c8018fc6203bd786304702409b8d86a4ba60cb3b14f6b82dc3f65c5c6e591f9ef9947605c76e9eadd4b1
+EBUILD sqlalchemy-2.0.37.ebuild 3882 BLAKE2B 24f7c5c82ba11a35b7bcb77f866843a3decfca71d3a3768a953a22b37e21e7dd5f0d728b9778fba114dc0b316ddeabc33f5d0b8559f86eea6d66f8106c9e8528 SHA512 69cb76a98474956b05c86e20ba38a4dcbcfeda02cd965c048d900f20ce44d08db59198d72e6eb48d783940a3930b8b67784383de1a03a45f14f1363f6fefae43
MISC metadata.xml 444 BLAKE2B 5fbfcf8f16e52ab5bb691b0b33a8491d94e42a80409114cd9b306af7d4b0eb8b6660fabc663adee53080c635217961301b78df536995b91afe9288d255f73d62 SHA512 b432b65ed3033d34ac0784d007909eb838b309b6a4785eebb1a3f808e43dfc41c786cd55e4dd048776c65127aac170bdd9fb9e5a8ae63accb5f65e300bca9676
diff --git a/dev-python/sqlalchemy/sqlalchemy-2.0.37.ebuild b/dev-python/sqlalchemy/sqlalchemy-2.0.37.ebuild
new file mode 100644
index 000000000000..c310c9c86fe8
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-2.0.37.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=SQLAlchemy
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="
+ https://www.sqlalchemy.org/
+ https://pypi.org/project/SQLAlchemy/
+ https://github.com/sqlalchemy/sqlalchemy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples +sqlite test"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/greenlet/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ test/ext/mypy/test_mypy_plugin_py3k.py
+ test/typing/test_mypy.py
+ # hardcode call counts specific to Python versions
+ test/aaa_profiling
+ )
+ local EPYTEST_DESELECT=(
+ # warning tests are unreliable
+ test/base/test_warnings.py
+ )
+ local sqlite_version=$(sqlite3 --version | cut -d' ' -f1)
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
+ test/ext/test_associationproxy.py::DictOfTupleUpdateTest::test_update_multi_elem_varg
+ test/ext/test_associationproxy.py::DictOfTupleUpdateTest::test_update_one_elem_varg
+ test/engine/test_processors.py::PyDateProcessorTest::test_date_invalid_string
+ test/engine/test_processors.py::PyDateProcessorTest::test_datetime_invalid_string
+ test/engine/test_processors.py::PyDateProcessorTest::test_time_invalid_string
+ "test/dialect/test_sqlite.py::TestTypes_sqlite+pysqlite_${sqlite_version//./_}::test_cant_parse_datetime_message"
+ "test/dialect/test_suite.py::ReturningGuardsTest_sqlite+pysqlite_${sqlite_version//./_}"::test_{delete,insert,update}_single
+ test/base/test_utils.py::ImmutableDictTest::test_pep584
+ 'test/sql/test_compare.py::HasCacheKeySubclass::test_init_args_in_traversal[_MemoizedSelectEntities]'
+ )
+ ;;
+ esac
+ if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[False-True]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-True]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[has_terminate-is_asyncio]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[not_has_terminate-is_asyncio]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True]"
+ )
+ fi
+
+ # upstream's test suite is horribly hacky; it relies on disabling
+ # the warnings plugin and turning warnings into errors; this also
+ # means that any DeprecationWarnings from third-party plugins cause
+ # everything to explode
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p rerunfailures --reruns=10 --reruns-delay=2
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "asyncio support" dev-python/greenlet
+ optfeature "MySQL support" \
+ dev-python/mysqlclient \
+ dev-python/pymysql
+ optfeature "postgresql support" dev-python/psycopg:2
+}