summaryrefslogtreecommitdiff
path: root/dev-python/sqlglot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-02 09:45:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-02 09:45:46 +0000
commita0c5e9067531830baf9160de325fe77145f02987 (patch)
tree7eaa500d69f3cea4dfb749d1c6e2eca49b71353f /dev-python/sqlglot
parentfd0a8825115ac9a61ceee1d37c0fdf4fd2e95b5f (diff)
gentoo auto-resync : 02:11:2023 - 09:45:46
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest2
-rw-r--r--dev-python/sqlglot/sqlglot-19.0.2.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index fb464840b0b1..1fadb9d4e3db 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1,3 +1,5 @@
DIST sqlglot-19.0.0.tar.gz 8955220 BLAKE2B 9f53b726efb379b72f93f55796ae110be2f0596c4e4156e4c67ba899b0138fd6abb28b0a800c6d79c58bba565cb551ad42c94c8fba26ffcea854ad94a35971f0 SHA512 ac679f5c2d911a46ca6c4183ae3542e7a436185f37af494c8a35b657e5fe552cfea2e7d6c142721bb2247f91d5ceda8f602cc54a80b19a3ed72a95d9a9ed4e82
+DIST sqlglot-19.0.2.tar.gz 8980868 BLAKE2B 07e6d0af365a45cdac27e7b976979bbd26b36931438928ca169fbfe18598a01b067a736cc0f2f97684c93e574d45f61d0c3f357c2c1321c6e344b7227817acce SHA512 3639e2e1c020c26893ae750bbf20669cf722e2e93e8438934db732c8e79791c61fa3363bf887455b04dee50ebe76fd8d689279fed22260a807a8b3b1f035c9c0
EBUILD sqlglot-19.0.0.ebuild 919 BLAKE2B d6c7bf029e48f9b11c305adbc89473b9bcb7277299a869569aeefe69dd63e4ac19c9a7e3c23ba8981e6d7f46b7e4611cbfcc18b871876e949e0912c3ded446bc SHA512 5f42256d970f291e0a0eed073a1060a1e5dc15b872b1ecca6b9aeceb380c48e1bb1f1b61719a582d8bd56e01eaf8b3578fd374ee7fff761ac6a95e746b07c2f9
+EBUILD sqlglot-19.0.2.ebuild 919 BLAKE2B d6c7bf029e48f9b11c305adbc89473b9bcb7277299a869569aeefe69dd63e4ac19c9a7e3c23ba8981e6d7f46b7e4611cbfcc18b871876e949e0912c3ded446bc SHA512 5f42256d970f291e0a0eed073a1060a1e5dc15b872b1ecca6b9aeceb380c48e1bb1f1b61719a582d8bd56e01eaf8b3578fd374ee7fff761ac6a95e746b07c2f9
MISC metadata.xml 635 BLAKE2B fb154da2feeea6d590b4f3edb8d8d90d316feee1b8faababc022db026254bd24674d8419b74074b089d4d8930bab642cdc5fa7694bfa9e033cb5ef4ad4988562 SHA512 dd5ed7212dc2eac6a4d84bb2e3639db1ffe163598d911073d7100a8ebfeceb85842ea2e6a597d1036d5b1388d18954b95a782af7b3a84479bf3b59ef9e9b6bf8
diff --git a/dev-python/sqlglot/sqlglot-19.0.2.ebuild b/dev-python/sqlglot/sqlglot-19.0.2.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-19.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}