summaryrefslogtreecommitdiff
path: root/dev-python/squaremap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/squaremap
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/squaremap')
-rw-r--r--dev-python/squaremap/Manifest3
-rw-r--r--dev-python/squaremap/metadata.xml15
-rw-r--r--dev-python/squaremap/squaremap-1.0.4.ebuild26
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/squaremap/Manifest b/dev-python/squaremap/Manifest
new file mode 100644
index 000000000000..56f45f01dad1
--- /dev/null
+++ b/dev-python/squaremap/Manifest
@@ -0,0 +1,3 @@
+DIST SquareMap-1.0.4.tar.gz 7439 BLAKE2B 34b5e5eaf45c597c4591eec291f0fa2e001f6df432eda0a3b98f8e596af257f1261d083b25eea25fedd9d415e00cc20e318f94fe2ce85b3abd2c20ccd51f2d3c SHA512 d01e61697571360b58e762787237bb8533b3de238f26323380a8b0b90d72d2f00e2a43e7f6742fbbb3483573493b0d83568e0651cbf9bdd463b911d09bf27e76
+EBUILD squaremap-1.0.4.ebuild 536 BLAKE2B 89663e62039a59b811c2566aa54d439853737f935f07a95256d3ada660ae6520dadc56d10ab1af0ed8582303b4104da7c0131a090c78dbc27c875b964b37601d SHA512 b3c52da42ab368d7afaec6c02caaa7b85c1cc8049b8bb48e0c0be7a5480586e908008dff5165d04bbdce1ed5618c21ef52dab5b0a749c4a881d878fb8387f20e
+MISC metadata.xml 436 BLAKE2B 18282b39ca0f1b7fc5982d2f29b65148f6333de3a509a478374b86b2f078aae8d0f2d200cbda0616d7d4018cbcaaab3fb03ce13889d3419fdba14a52c245d0de SHA512 dce36b184260ccdea3585f5f688006a438347cbe18b2358d95fce4f96f3675d5f0f9a8080a814ac56bc58332d901dc9272f00b6085b8e3e0f0ccfeb9e25f497e
diff --git a/dev-python/squaremap/metadata.xml b/dev-python/squaremap/metadata.xml
new file mode 100644
index 000000000000..b6d7cc2ced82
--- /dev/null
+++ b/dev-python/squaremap/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>swegener@gentoo.org</email>
+ <name>Sven Wegener</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">SquareMap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/squaremap/squaremap-1.0.4.ebuild b/dev-python/squaremap/squaremap-1.0.4.ebuild
new file mode 100644
index 000000000000..70cb764465fe
--- /dev/null
+++ b/dev-python/squaremap/squaremap-1.0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+MY_PN="SquareMap"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Hierarchic data-visualisation control for wxPython"
+HOMEPAGE="https://pypi.org/project/SquareMap/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/wxpython"
+
+S="${WORKDIR}"/${MY_P}