summaryrefslogtreecommitdiff
path: root/dev-python/starlette
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-23 19:24:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-23 19:24:10 +0000
commit575bcb9220287a6f0d2577db1fd9fe55d9d8b745 (patch)
tree52f12cfa140d4839d32305dd42eebe34e9686234 /dev-python/starlette
parent4c5bd80830992553e02f099442277e10ee97372d (diff)
gentoo auto-resync : 23:02:2025 - 19:24:09
Diffstat (limited to 'dev-python/starlette')
-rw-r--r--dev-python/starlette/Manifest2
-rw-r--r--dev-python/starlette/starlette-0.46.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 95cbce65f5d8..758e9711f271 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1,3 +1,5 @@
DIST starlette-0.45.3.gh.tar.gz 2574214 BLAKE2B e3a1c44288ba8d2da558417d14a2787a7c00c689298074b4ac9ce330d90e17181d98ad2ed85795bcea408ee2a64d287dec14ce5c7f9dfc79507562697b83511a SHA512 45d3726ce794a7572e4c816fa3eb1a8a9ad2c110757200b4f6e1aed0d502d2cc293e29c5b282d3451c9770ea067cfb684176755bf2d261fdb22de111ef8a1542
+DIST starlette-0.46.0.gh.tar.gz 2575846 BLAKE2B f71379bc9157a9ca6bf9b058a625c97219d8334967fc7f21d0d4efb13feea0088946e6802264aa9a042bf7e26414188c3560b6642f7b22d923381218fe326a05 SHA512 24d35d50bbdc1433b7203a3f74b43d2c303bdf4ed3b4a9ca5f0635c22a03ef35b34569fb99376ba3244520af2045209480152851c9d48172b1b1537424ae16fe
EBUILD starlette-0.45.3.ebuild 1363 BLAKE2B efd4ff59650d7c67297c569ea59e18ea79e090c59baedeb282b73d3c5f4c9d6f6670b65816bfb69145b4a4aff6bb821d5ffc59a6bb2b1190436daa40f65def5e SHA512 749b9932b1a098077ea18de02cd79a7cb16a558902eabbe19ecca55ba59c6e7a61fd2ac06815a04e8d486037f03af380028119f83c2073eb5455f41a9eeb780e
+EBUILD starlette-0.46.0.ebuild 1371 BLAKE2B f906e497de27bfa62c5bbefa34d8348c3d5f85c9974a8b8768c9fe684b36b385c440baf4b7ff8adade9f9ccaa19f61ee70893666492a616096dd46ba33114e0c SHA512 5dae5ae4796b6bef7b179117f61b72c9ab850bc535327fd95150a715aae526e118ff583c01422ede611072825e59aeb9a3037f56e34d67ad1f45c838beb7e257
MISC metadata.xml 371 BLAKE2B 0ccaa4659e63162b565359a1cae05764bea66d708a5f4af1a4716ba9ba23faa39ab4f5a806c0a9783f3f42282ee9b98e22a92f2b308b8dfe97bbf9c770a8add1 SHA512 0fc326941861260becd4129c8a351e89ba0f98f9a3ce9b5d50812f0eaf667743ab0d403889aa1b0a2d9fcedbe0212ba879d165ec8edd115686d4768e6b1326ca
diff --git a/dev-python/starlette/starlette-0.46.0.ebuild b/dev-python/starlette/starlette-0.46.0.ebuild
new file mode 100644
index 000000000000..c9c7fb5ea4c2
--- /dev/null
+++ b/dev-python/starlette/starlette-0.46.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.6.2[${PYTHON_USEDEP}]
+ <dev-python/httpx-0.29[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja2[${PYTHON_USEDEP}]
+ >=dev-python/python-multipart-0.0.18[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+: ${EPYTEST_TIMEOUT:-180}
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p anyio
+}