summaryrefslogtreecommitdiff
path: root/dev-python/statsmodels
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-18 04:54:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-18 04:54:42 +0000
commit5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (patch)
treec968fff3108e2b4d88e4e564a56bfd066f170573 /dev-python/statsmodels
parent1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (diff)
gentoo resync : 18.03.2018
Diffstat (limited to 'dev-python/statsmodels')
-rw-r--r--dev-python/statsmodels/Manifest1
-rw-r--r--dev-python/statsmodels/statsmodels-9999.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/statsmodels/Manifest b/dev-python/statsmodels/Manifest
index ee26a9478b00..0aa361f2ffb1 100644
--- a/dev-python/statsmodels/Manifest
+++ b/dev-python/statsmodels/Manifest
@@ -4,4 +4,5 @@ DIST statsmodels-0.6.1.tar.gz 6980841 BLAKE2B 5ac16df0fc06d051cc79d037bd3a9b0975
DIST statsmodels-0.8.0.tar.gz 9464851 BLAKE2B f4bcf38c0292dcdfef9e3e34519f4dff004795bf76f54773f551c6c767f16f9cee0a2756408cff6f727df8eebc269bccf2c8bd28915a729eb022eba34831628e SHA512 32bb7f36acc16796c445e5f695d958af4525fbbb2d374376fb4a73c972e3796fad05532456cef4aa5ee59d6fce11921174e17bbfc2e05d2488ce1ceac5175239
EBUILD statsmodels-0.6.1.ebuild 1780 BLAKE2B 64aae493e2e32a3b56aba759b0f9cc2cc093f206d82fe7dd88e73242ea316c4f12948668ad2d26f67e43c36b06dd3bc95b17d35ba2fb650f25aa948d2a629653 SHA512 dde6908cb7d8d70721e022aeca4ad460c2dfc03426a407f3daebc327f1d89591a570a360e56a3c0d2227bae51e9bc1b7209e1790a4ee2543f5c9c49f199b4a27
EBUILD statsmodels-0.8.0.ebuild 1936 BLAKE2B aea2b9f390d8c73ada520aa41f613fb5608b5bc7173348269910af28ef1bba8009da15ec0e3234c49ec1422ca80e7060a92fcb8ee8bdd2278754befded1e02fe SHA512 46af987b7bfd458272f5831b7ba1f58978f309dacbd3d36b41f770c5fff56dd17d73babf3e2544d1aebb7cb30cef63c54ddc5b291ccd9af9c8e94ffd24bc0a27
+EBUILD statsmodels-9999.ebuild 1901 BLAKE2B 24151ad7539628a2a0abadeb1ec851fa9eb1c36d0e871fff40293a727307234f296b6a457667a49c50eb2fb61b8da8ee7ae58416637ec85bc85a9d83f523bd19 SHA512 9f09688ace7ec2535586747ac3b17a9c004064e4336a6cd3de6f244ff95fc9bbd771fc224616480570c57c6f11972d966c4c6ba0f1b9ab571fe46aa679d9bb3c
MISC metadata.xml 1075 BLAKE2B 86672821dcfcd4f52b35f953c2024646ac8bcd937b30ce7fd8c0d1411d5cefe64cc7e8943d1b073c81fbbb4cdee348b30c93fd8145651088f8f88d01ca9e742d SHA512 7e9c385a1820da33e55db49d582d750f01fd11c0dd1616470f2cd71f12c673010cf76c8af984472daa8787704d353f2d42f60798e419d182c9e24ba4dd7dd97f
diff --git a/dev-python/statsmodels/statsmodels-9999.ebuild b/dev-python/statsmodels/statsmodels-9999.ebuild
new file mode 100644
index 000000000000..d0a074fec050
--- /dev/null
+++ b/dev-python/statsmodels/statsmodels-9999.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 git-r3 virtualx
+
+DESCRIPTION="Statistical computations and models for use with SciPy"
+HOMEPAGE="http://www.statsmodels.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/statsmodels/statsmodels.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc examples test"
+
+CDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+RDEPEND="${CDEPEND}
+ examples? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+"
+DEPEND="${CDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "/sphinx.ext.intersphinx/d" -i docs/source/conf.py || die
+ export VARTEXFONTS="${T}"/fonts
+ export MPLCONFIGDIR="${T}"
+ export HOME="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx -b html --build-dir=docs/build
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ virtx nosetests -v || die
+}
+
+python_install_all() {
+ find "${S}" -name \*LICENSE.txt -delete
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Plotting functionality" "dev-python/matplotlib"
+}