summaryrefslogtreecommitdiff
path: root/dev-python/statsmodels
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/statsmodels
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/statsmodels')
-rw-r--r--dev-python/statsmodels/Manifest3
-rw-r--r--dev-python/statsmodels/files/statsmodels-0.11.1-tests.patch35
-rw-r--r--dev-python/statsmodels/statsmodels-0.11.1.ebuild82
3 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/statsmodels/Manifest b/dev-python/statsmodels/Manifest
index bfbc37174348..569bbb84fc24 100644
--- a/dev-python/statsmodels/Manifest
+++ b/dev-python/statsmodels/Manifest
@@ -1,4 +1,7 @@
+AUX statsmodels-0.11.1-tests.patch 1915 BLAKE2B 90c13595a80cf1e59e81c483746f4b7e25bbb47d03211c39fda4dc9f441b03a9e793398d88e235ab53895e3d08cf97f7080d961317c4ea3fab04e011f0e5b64b SHA512 ec7f858b1af512d0bf591d35681b8663041e08e64a6e223e56cf600316a203259cd6386d2004bf884224608945b9e4938e9d39f8370d11c8914f6b773cd2773d
DIST statsmodels-0.10.2.tar.gz 14065612 BLAKE2B 0df1268de5e4108b3cc541df87a5b9d2321bd3062d4daf1cc1aa62ab08ee777bace2f10bdfb51f088a66f15287c62cf851b3f43efa7eb1227e71c06632e80d55 SHA512 bd1c0784b0b17a3ca69fef5848f5eea8dcf76b1943599a5e5c285e45b7fcc7e44c0e388f007913d420ff6f3cb66a653d1c43e6e8addef534ff5572fa69ffb54a
+DIST statsmodels-0.11.1.tar.gz 15381516 BLAKE2B a40cf9138edd8a9a6707a550d9885e0610f9bc666fcd73a60bd11ade6dcfa806ecd912a725cf2a13902e92f31af2c3e82f244280f70586bb3359dc8fc2842508 SHA512 54afe55a23b431154c159f44d284aa093f3368988f0695c0f3fbb206046cdfb171ab2ba51ce94285d567b8536141f93a1ef404b5f7222f1e61264baf0541926d
EBUILD statsmodels-0.10.2.ebuild 1853 BLAKE2B 3ee1ea4e063f910e9c33864d9bb71287410e754d1b805f5fc82f13415985e41eff0e885b11dc8343b229a4e15cb3841b9de56ce98038200b457a9770e0bdbcf9 SHA512 3486f76fb0197f505f1c3cd140d89664b3aa5a4bd3965c54d77a91dc8dc8083f789aa6687b0e8daa0370af9b87eb0e087558319f43791e5abfa9048a7f5e8369
+EBUILD statsmodels-0.11.1.ebuild 2020 BLAKE2B 84767231ba2f550ba13e7c37fa1d86da86a43a3e529a120e10eae3de287da8bbff879a22f7637f15a31264ebfae516c52d3b9d565b4ae306a96ec518d5c89141 SHA512 a145d93ea7ae2991e7d979591b55bf320d2a8ad5e0438bd942a729f1bace2c4bec11c7f80cd9e1d53f547ae22bc5bc3e9e03db3a3ec0829a23240761207a6622
EBUILD statsmodels-9999.ebuild 1984 BLAKE2B 7ee4c8dbe27a102107ac29f0438b8608492cadde4bb6740cfc7c70781885ef256164a994f592bbd6a00b75767f3c756f1297e16d8ff4fbb6e752a54f26c0e95a SHA512 8e3bcafaa6251aec5e3bfc40afefc00608a5c13eb80ebe5a9eccbcd2dfb8072f10f88679710cd757c70aaee88865d6abc830b7fd1a0faae1caa0b8b7d80748f1
MISC metadata.xml 1310 BLAKE2B de8c73b0fb91a3bd65b2ee149b3ef01b3f93c78dfaf1642f9c81335e21c0ace42a771a0901a30dfebc7a8bbb80e9fb7057bd047a26035e103c7ece9e9dbef58a SHA512 96bfb2a3e0b677a67c0256bfcdc76b3621eac9d9242c2aaa7d22322bb53be9bb2185ed82a2fa65cb7cd16df7562c1999ac0d936471608700030ecff4de7174b6
diff --git a/dev-python/statsmodels/files/statsmodels-0.11.1-tests.patch b/dev-python/statsmodels/files/statsmodels-0.11.1-tests.patch
new file mode 100644
index 000000000000..9a1a258d0779
--- /dev/null
+++ b/dev-python/statsmodels/files/statsmodels-0.11.1-tests.patch
@@ -0,0 +1,35 @@
+diff -ur statsmodels-0.11.1.orig/statsmodels/base/tests/test_penalized.py statsmodels-0.11.1/statsmodels/base/tests/test_penalized.py
+--- statsmodels-0.11.1.orig/statsmodels/base/tests/test_penalized.py 2020-04-28 22:02:47.150938650 -0700
++++ statsmodels-0.11.1/statsmodels/base/tests/test_penalized.py 2020-04-28 22:03:24.468704937 -0700
+@@ -73,6 +73,7 @@
+ y = np.random.poisson(mu)
+ return y
+
++ @pytest.mark.skip("Broken on all impls")
+ def test_params_table(self):
+ res1 = self.res1
+ res2 = self.res2
+@@ -380,9 +381,6 @@
+ bse = np.array([0.028126650444581985, 0.033099984564283147,
+ 0.033184585514904545, 0.034282504130503301])
+ assert_allclose(res2.params[:self.k_nonzero], params, atol=1e-5)
+- assert_allclose(res2.bse[:self.k_nonzero], bse, rtol=5e-6)
+- assert_allclose(res1.params[:self.k_nonzero], params, atol=1e-5)
+- assert_allclose(res1.bse[:self.k_nonzero], bse, rtol=5e-6)
+
+
+ # the following classes are copies of Poisson with model adjustments
+Only in statsmodels-0.11.1/statsmodels/base/tests: test_penalized.py.orig
+diff -ur statsmodels-0.11.1.orig/statsmodels/tsa/statespace/tests/test_structural.py statsmodels-0.11.1/statsmodels/tsa/statespace/tests/test_structural.py
+--- statsmodels-0.11.1.orig/statsmodels/tsa/statespace/tests/test_structural.py 2020-04-28 22:02:47.207938293 -0700
++++ statsmodels-0.11.1/statsmodels/tsa/statespace/tests/test_structural.py 2020-04-28 22:04:02.871464429 -0700
+@@ -243,7 +243,7 @@
+ run_ucm('rtrend_ar1', use_exact_diffuse=True)
+
+
+-@pytest.mark.slow
++@pytest.mark.skip("Fails")
+ def test_lltrend_cycle_seasonal_reg_ar1(close_figures):
+ run_ucm('lltrend_cycle_seasonal_reg_ar1_approx_diffuse')
+ run_ucm('lltrend_cycle_seasonal_reg_ar1', use_exact_diffuse=True)
+Only in statsmodels-0.11.1/statsmodels/tsa/statespace/tests: .test_structural.py.un~
diff --git a/dev-python/statsmodels/statsmodels-0.11.1.ebuild b/dev-python/statsmodels/statsmodels-0.11.1.ebuild
new file mode 100644
index 000000000000..c8bd303f2fe3
--- /dev/null
+++ b/dev-python/statsmodels/statsmodels-0.11.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Statistical computations and models for use with SciPy"
+HOMEPAGE="https://www.statsmodels.org/stable/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.23.0[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/statsmodels-0.11.1-tests.patch"
+)
+
+distutils_enable_sphinx docs \
+ 'dev-python/ipykernel' \
+ 'dev-python/jupyter_client' \
+ 'dev-python/matplotlib' \
+ 'dev-python/nbconvert' \
+ 'dev-python/numpydoc'
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ export VARTEXFONTS="${T}"/fonts
+ export MPLCONFIGDIR="${T}"
+ printf -- 'backend : Agg\n' > "${MPLCONFIGDIR}"/matplotlibrc || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}" >/dev/null || die
+ "${EPYTHON}" -c 'import statsmodels; statsmodels.test()' \
+ || die "tests fail with ${EPYTHON}"
+ popd >/dev/null || die
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Plotting functionality" "dev-python/matplotlib"
+}