summaryrefslogtreecommitdiff
path: root/dev-python/stdio-mgr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/stdio-mgr
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/stdio-mgr')
-rw-r--r--dev-python/stdio-mgr/Manifest3
-rw-r--r--dev-python/stdio-mgr/metadata.xml22
-rw-r--r--dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild32
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/stdio-mgr/Manifest b/dev-python/stdio-mgr/Manifest
new file mode 100644
index 000000000000..e6edeca5d760
--- /dev/null
+++ b/dev-python/stdio-mgr/Manifest
@@ -0,0 +1,3 @@
+DIST stdio-mgr-1.0.1.tar.gz 8447 BLAKE2B 72038ea34177829d77ac239585775557b5a0a253879c027b2aad64045ec8bafbfdc250d94fe61cde96f06616f774edf42b384bfef7fbf69af442b0a9b703cf9a SHA512 2d18e5d65faa7a73373b56fdac3893768a65a36bed17f017b647e71431a6bff44ce1d39022f1dbbd31ddc9c0e704743a164f4b7610fb62d75aa34ecb53331366
+EBUILD stdio-mgr-1.0.1.ebuild 770 BLAKE2B 750b8847d1edee2c16b70ab5b5e10674b1ca18db9ea22625e8bf90d725839b3478be6c76cfda38dc7ba846d6aea8737b9ee63a05e0829413288aeba2bebd99dc SHA512 09b20c55b358453d677edf6812de3b7e8e142b1b602e2bcc6d724b97dc4ebb877da87e03d4c5a12185c863fa99f298b663feab5040394c22624e2d29efb5a0b5
+MISC metadata.xml 913 BLAKE2B b98d63af5f5319b7e6b8fd1525a3eb761fd9882caa82e798b35c9f20e150d038c5a69ead06f7dee1b8cbab1adc539b13c025ecdbfc9476b49f74930c15b15eaf SHA512 c15ccd5cccd925c9c2a5821c66ef2babe90c3bf54e1ecd0473b6e02e869649600b503c9c32669180db74b1a4464c75ebbbf39f08d1896b5903bc3fa4d8811311
diff --git a/dev-python/stdio-mgr/metadata.xml b/dev-python/stdio-mgr/metadata.xml
new file mode 100644
index 000000000000..cfe2eacab93b
--- /dev/null
+++ b/dev-python/stdio-mgr/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <longdescription lang="en">
+Have a CLI Python application?
+
+Want to automate testing of the actual console input &amp; output of your user-facing components?
+
+stdio Manager can help.
+
+While some functionality here is more or less duplicative of redirect_stdout and redirect_stderr in contextlib within the standard library, it provides (i) a much more concise way to mock both stdout and stderr at the same time, and (ii) a mechanism for mocking stdin, which is not available in contextlib.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bskinn/stdio-mgr</remote-id>
+ <remote-id type="pypi">stdio-mgr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild b/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
new file mode 100644
index 000000000000..4c032aa553ed
--- /dev/null
+++ b/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Context manager for mocking/wrapping stdin/stdout/stderr"
+HOMEPAGE="
+ https://github.com/bskinn/stdio-mgr/
+ https://pypi.org/project/stdio-mgr/
+"
+SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND=">=dev-python/attrs-17.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+# doc directory is not included in the release tarball for some reason
+#distutils_enable_sphinx doc \
+# dev-python/sphinxcontrib-programoutput \
+# dev-python/sphinx_rtd_theme
+
+python_test() {
+ # skip the doctests
+ epytest tests
+}