summaryrefslogtreecommitdiff
path: root/dev-python/stdio-mgr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-31 15:23:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-31 15:23:38 +0100
commita407e25d814596ca802d83102671d95e00079767 (patch)
treeb0d4824cf74ddca3ee380c618ffae855cd0d1bcd /dev-python/stdio-mgr
parent441510fa20665b7920b149994e72b3a1cd62a813 (diff)
gentoo auto-resync : 31:05:2023 - 15:23:38
Diffstat (limited to 'dev-python/stdio-mgr')
-rw-r--r--dev-python/stdio-mgr/Manifest2
-rw-r--r--dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/stdio-mgr/Manifest b/dev-python/stdio-mgr/Manifest
index 434ab00ed4fb..a899e088eba8 100644
--- a/dev-python/stdio-mgr/Manifest
+++ b/dev-python/stdio-mgr/Manifest
@@ -1,3 +1,5 @@
+DIST stdio-mgr-1.0.1.gh.tar.gz 8447 BLAKE2B 72038ea34177829d77ac239585775557b5a0a253879c027b2aad64045ec8bafbfdc250d94fe61cde96f06616f774edf42b384bfef7fbf69af442b0a9b703cf9a SHA512 2d18e5d65faa7a73373b56fdac3893768a65a36bed17f017b647e71431a6bff44ce1d39022f1dbbd31ddc9c0e704743a164f4b7610fb62d75aa34ecb53331366
DIST stdio-mgr-1.0.1.tar.gz 8447 BLAKE2B 72038ea34177829d77ac239585775557b5a0a253879c027b2aad64045ec8bafbfdc250d94fe61cde96f06616f774edf42b384bfef7fbf69af442b0a9b703cf9a SHA512 2d18e5d65faa7a73373b56fdac3893768a65a36bed17f017b647e71431a6bff44ce1d39022f1dbbd31ddc9c0e704743a164f4b7610fb62d75aa34ecb53331366
+EBUILD stdio-mgr-1.0.1-r1.ebuild 892 BLAKE2B d6a513b425efc7d2caf5341f4e98280aba10cb93d8898953002b3f64b6ca1e658e4d423f147b6af7980a3acbe3148c79bacfe17874b6d4000d1b055dfadac3b4 SHA512 92b19542759f7ed4bbe8dbe94332afcbf69de19da41d8871e8add08344109f08f72dff1c99f807e99a7e0e8d9c7bab890662abaa875000b67d9da8f513751ffc
EBUILD stdio-mgr-1.0.1.ebuild 837 BLAKE2B cbb6199b3be9a73aeb79fdbf6fadb441a18f406c8f2f19267486c3f1eb5f4f57b3346f6445bf333ab93527ca61d325b1785f085df3e4b2dcd5ed0939b829198d SHA512 dd11b9539964f7658f0188a3257cf7257c78949a5c8f70efd2ae7bdd7ad682a63a0698023ff69a98970ba932cc110bfb30d7e93f83d7db92b607478aa81723b6
MISC metadata.xml 843 BLAKE2B 28d7e9188dfbf2da64435abcf5fc87d7440ca4b676f74da1d50f2038bc1ca786619f40476c967bf96904acb00f8be4ddc353b5884826d86cb33308ee1660022b SHA512 e0e914175cb2f69f9c11afe26b74178f16bf10d37bc35ee67ce55e9f3347e485a89db3af81ef5c0cba4daee8c167a0daaa7c927261d718007b09c2f9d8a35306
diff --git a/dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild b/dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..b6ac9b7058fc
--- /dev/null
+++ b/dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Context manager for mocking/wrapping stdin/stdout/stderr"
+HOMEPAGE="
+ https://github.com/bskinn/stdio-mgr/
+ https://pypi.org/project/stdio-mgr/
+"
+SRC_URI="
+ https://github.com/bskinn/stdio-mgr/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/attrs-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+# doc directory is not included in the release tarball for some reason
+#distutils_enable_sphinx doc \
+# dev-python/sphinxcontrib-programoutput \
+# dev-python/sphinx-rtd-theme
+
+python_test() {
+ # skip the doctests
+ epytest tests
+}