summaryrefslogtreecommitdiff
path: root/dev-python/stevedore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/stevedore
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/Manifest4
-rw-r--r--dev-python/stevedore/stevedore-3.5.0.ebuild (renamed from dev-python/stevedore/stevedore-3.4.0.ebuild)21
2 files changed, 20 insertions, 5 deletions
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
index 387f3a13d0e1..0ba7b5fda33a 100644
--- a/dev-python/stevedore/Manifest
+++ b/dev-python/stevedore/Manifest
@@ -1,3 +1,3 @@
-DIST stevedore-3.4.0.tar.gz 513360 BLAKE2B 17030d1aa3cfb566e6f589120eeb6241a1bc0a0dbac0825c48fc96b16316348e7b5e87c6c7fe428faf46cb9e2abbb0da6465f404d5a1fb767fb07c5d8078e481 SHA512 a63897c65fe8deb1b900c4279ce38856863a2581f8e0dec3fc082d0bd6daa5f346bfc6af978b73c3ac24215953c1376a973b800ff8dbbdc1a99f52c99bed7d6d
-EBUILD stevedore-3.4.0.ebuild 998 BLAKE2B f34223be4d4ff0d1c2d7d372247354f7160f649da7044eecb6b9f420041a6a7fe308aad767ac340dbe13361a83539f44c65eef53decb632fdf3218a950d7a9b5 SHA512 2f110950be41992100abe8225423de1c9ea1121e12815afb7107459531aaef231c697e35a078a5faaf8416598412d8f7eaae58f1224187163cb096af526c1b6c
+DIST stevedore-3.5.0.tar.gz 513548 BLAKE2B bb9b1968dbfdbce0764b0c2030e5d555e159e04a88d8fbdb151d3146e7940643c761ff476f7d950c2e83501b9b125e8323a8463d8b4b93b79cc76ddf2f71a362 SHA512 be0f82230d7d4d3cf18dd913e11093ad90744e32a3021d9f88f0be244f56d0e3606af0adef67674c569c41d885837be3f0fc4d58009e036151cc67963a4f2ab3
+EBUILD stevedore-3.5.0.ebuild 1363 BLAKE2B 0cb8470e708b39241344715f9b94b748db6d9f2db043c6c547fce4fad8abb8a47cf46f4a298bff41ddeaf9c7ab5b37de45731dc742ea20ab6e30741c1955c37b SHA512 dfd1ab0f730270f83e50293092e6a5be1aafa01273694c40b34d42409fddf919545e1a032b7a36a9b785b00836204ecbcbcfd134783550c80059365806a48d97
MISC metadata.xml 522 BLAKE2B 3ed51cb439d8350ff3df20a20a803c14bb11c9e0e5b15bd661f5780513f88a38f8a4d80703f6a7764488aa721f0fbbbf9a25d4fccb0f9916423198daa539bb69 SHA512 d08e11153dbb878de8f93d7a8293ddf2469adad8a2c436ef652f5c7cda7696a91f914260b841b3e64b3aab37d70dc76b1c369a08b9ef4bbd4f7c33c6a0ece690
diff --git a/dev-python/stevedore/stevedore-3.4.0.ebuild b/dev-python/stevedore/stevedore-3.5.0.ebuild
index fb6171da6fc8..f7b722d6adc9 100644
--- a/dev-python/stevedore/stevedore-3.4.0.ebuild
+++ b/dev-python/stevedore/stevedore-3.5.0.ebuild
@@ -3,16 +3,22 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
+HOMEPAGE="
+ https://opendev.org/openstack/stevedore/
+ https://github.com/openstack/stevedore/
+ https://pypi.org/project/stevedore/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 sparc x86"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
@@ -34,5 +40,14 @@ distutils_enable_sphinx 'doc/source' \
python_prepare_all() {
# Delete spurious data in requirements.txt
sed -e '/^pbr/d' -i requirements.txt || die
+
+ # Known bug in tests
+ # https://bugs.launchpad.net/python-stevedore/+bug/1966040
+ sed -i -e 's:test_extras:_&:' stevedore/tests/test_extension.py || die
+
+ # Also known problem, inside venv
+ sed -i -e 's:test_disable_caching_file:_&:' \
+ stevedore/tests/test_cache.py || die
+
distutils-r1_python_prepare_all
}