summaryrefslogtreecommitdiff
path: root/dev-python/storm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/storm
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/storm')
-rw-r--r--dev-python/storm/Manifest5
-rw-r--r--dev-python/storm/metadata.xml11
-rw-r--r--dev-python/storm/storm-0.20-r1.ebuild63
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/storm/Manifest b/dev-python/storm/Manifest
new file mode 100644
index 000000000000..f273d135937c
--- /dev/null
+++ b/dev-python/storm/Manifest
@@ -0,0 +1,5 @@
+DIST storm-0.20.tar.bz2 213069 SHA256 1fe016c9ec40520eafc3cf359f1ec2b7fa86be91e45c9279bfb0ea3b06390a82 SHA512 7a22c6a6fa45f7bbeeb5c6f934d6f889a6d90d78a6d3e3b9c6a6825485ec35301f573d08c619693a2587e795582db633254631c0be7cd8f1fee6b03a88378a8d WHIRLPOOL e18fb39e127eedd0f7691fc9b3c043b79da02beaab8088dc1f461cfdd23c91034ae6dbf3450a778ea2e06b93239463d5813015f5b6b6901f775da38b4188d2b1
+EBUILD storm-0.20-r1.ebuild 1952 SHA256 c20326a43880d92e0f43e77bc02031b5c43a3aa19046fa8cce94bc5a5338cad6 SHA512 f779ff7d9ed2be0500e3ef3433ab82c24078b7c05040aa412b4f52b20e734df4baa8926cba0b777762ea466f5f3340333fc4cb5e16675e8a9235018bdce4ddac WHIRLPOOL 0c81e905d8d6ad8f10e1817e6fbcfbac1f3ab055a660d38331ae5908bf03132c3cdb619de5f21713ce276e388b8a44e8fe7a921592dcfd1bfb2b88321029277a
+MISC ChangeLog 2922 SHA256 b69e25ecd7d8c9736ea9d1ade81705378b76f29bf50424e9402a2c900c439ac0 SHA512 0f7c9320d2cc11cf123e065ba530171b3a4b7cea9fdb909fc5eb740d64841c33bc715f48608873a5db8d981dc7c46a6dc5d1a919d09f67dfb4d01a8976215e7a WHIRLPOOL b0094d4238121dd4af6d48001f3e264c077f45b8fb27892f151c8e218c759cce4896be2a073052d77dcf58236b740c7faf8232dfdc94ca01f2ab753c73b1903f
+MISC ChangeLog-2015 3052 SHA256 a3de21a6b7b365816f26eb5e1e11e71ed2e13f58c38fba553b4372723bf0a871 SHA512 2efbb29cfa6b4a310a06d8853cae3343b710d41a9afe0879363ecd590ee68913cf2317f2f721d17aeb490fbe8fb05468967dd6cd6c6fc15cb3b199f229ef99a3 WHIRLPOOL 0192cc7742aa2562fa6b6e2190708be7cdeebb98a4af9fb2957c418c36219eb9d39d1822dc9060feb2ab927378af741e46d8a9a5a41321cf3be0901d43b681d2
+MISC metadata.xml 313 SHA256 841713c29bae7fb1fd248ba5dd9c94aad945ca94fd37c92ad54aa07cf4abb4ce SHA512 ea41959e22a82110ac4c87551d1f41b02b6f190da6ca140335c085137db32af3a56abcfb517f5086af12990a289223fd920f1ddd4a60b59d81cc3dcdee630965 WHIRLPOOL 492921c5e1f9f2ce425f29fc9dd5720bac68287ba6a23c83ac7c74def044d51517c5d88ff73b58df14b40edf414ab73931c7540e72b388db381e8e9e77fdf92c
diff --git a/dev-python/storm/metadata.xml b/dev-python/storm/metadata.xml
new file mode 100644
index 000000000000..5ff1e589f865
--- /dev/null
+++ b/dev-python/storm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">storm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/storm/storm-0.20-r1.ebuild b/dev-python/storm/storm-0.20-r1.ebuild
new file mode 100644
index 000000000000..4d02bf52610a
--- /dev/null
+++ b/dev-python/storm/storm-0.20-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="An object-relational mapper for Python developed at Canonical"
+HOMEPAGE="https://storm.canonical.com/ https://pypi.python.org/pypi/storm"
+SRC_URI="https://launchpad.net/storm/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql postgres sqlite test"
+
+RDEPEND="mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( =dev-python/psycopg-2*[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/fixtures[${PYTHON_USEDEP}] )"
+
+DOCS="tests/tutorial.txt"
+
+pkg_setup() {
+ append-cflags -fno-strict-aliasing
+ python-single-r1_pkg_setup
+}
+
+python_prepare_all() {
+ sed -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" \
+ -i setup.py || die
+
+ # delete rogue errors in setting exceptions
+ sed -e '/module_exception is not None:/d' \
+ -e '/module_exception.__bases__ += (exception,)/d' \
+ -i storm/exceptions.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if use mysql; then
+ elog "To run the MySQL-tests, you need:"
+ elog " - a running mysql-server"
+ elog " - an already existing database 'db'"
+ elog " - a user 'user' with full permissions on that database"
+ elog " - and an environment variable STORM_MYSQL_URI=\"mysql://user:password@host:1234/db\""
+ fi
+ if use postgres; then
+ elog "To run the PostgreSQL-tests, you need:"
+ elog " - a running postgresql-server"
+ elog " - an already existing database 'db'"
+ elog " - a user 'user' with full permissions on that database"
+ elog " - and an environment variable STORM_POSTGRES_URI=\"postgres://user:password@host:1234/db\""
+ fi
+
+ # Some tests require a server instance which is absent
+ "${PYTHON}" test --verbose || die
+}