summaryrefslogtreecommitdiff
path: root/dev-python/sybil/sybil-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
commitadb727afeb568404873e8cbc91ba93d3d49eff13 (patch)
treed86cdceda93a48d792f162c7b5f054f09c41ee73 /dev-python/sybil/sybil-4.0.0.ebuild
parented94061721073b4f7b546c30ae337f5737939985 (diff)
gentoo auto-resync : 26:12:2022 - 14:07:48
Diffstat (limited to 'dev-python/sybil/sybil-4.0.0.ebuild')
-rw-r--r--dev-python/sybil/sybil-4.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/sybil/sybil-4.0.0.ebuild b/dev-python/sybil/sybil-4.0.0.ebuild
new file mode 100644
index 000000000000..a54934b5878a
--- /dev/null
+++ b/dev-python/sybil/sybil-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest