summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-20 00:15:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-20 00:15:26 +0000
commit1534d50aaf24272ec425fa439389ef7e1f7bf174 (patch)
treec48ca34f49e5c335c0d06b96d9f09d4a74e144d5 /dev-python/sybil
parent2e512e4e32285f8c4eb19586d014cb9d31454ec9 (diff)
gentoo auto-resync : 20:02:2025 - 00:15:26
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest2
-rw-r--r--dev-python/sybil/sybil-9.1.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 93b57597d979..61fd0ad22d22 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,3 +1,5 @@
DIST sybil-9.0.0.gh.tar.gz 75154 BLAKE2B adc04da47539cb17001538776f1b73c2a27eae07fcc63ace38925fb46e2679f21133354b78da02299d9f87d047d68ee4ba623fc555c9efd17e965a067e8c8646 SHA512 098efe001c17606cbf3ab4095ca9b85e784a13af67d48d898a2622c18c6a506507ba7dddd43a232bb8c270734b9fadb24aeff356833a854a45285521a06c3ed8
+DIST sybil-9.1.0.gh.tar.gz 75369 BLAKE2B db9397d212042ea230b6357f8003d620a45e9b8332f7f326cbc7d6dbc188c9c72bac105871a2b56b51e28d6149535aa86c732fbb28ff63f6d265c3751f129e11 SHA512 1b0498ed14114398d0580eb35f3a6c693bc2bbef9cec47beb7084581e82487b15b6fd5266c2cb8927ea412624e3c1a66c65f14f6007196ab7aa9dcd0668cd3d8
EBUILD sybil-9.0.0.ebuild 887 BLAKE2B de491417aa76861629588c32945868ee348ec5997b4a4b49b1fcd4ec4ed87cb9bd61aba1c34d49ea5ea6cb7247e1235ecab6b655a62610797ff8985df4f66e8b SHA512 0a336e73e870b11cc14aaf55cd1db2106feb3a669912d80dc4b20c233fcf5f43b1b67c67885bd52975079c53244238612ca91891df4a92ab6eeeacf261553a3b
+EBUILD sybil-9.1.0.ebuild 894 BLAKE2B b65b09ef2dcd9564a03310120c3ee03939b451a29b76bbe3687a5c6d33ef1ff6fee8589976f30d6cd16da07c02fd18b093f6de8a72e17d2e7c132b878db53679 SHA512 f27318660ac68e5ce9cde2f5fd2e6ceaad4a364bb455eaf0cb4868d820d7422adcecea1fe586df38df106c2ab4c35f83b2d8814ee1b952f095a123af0088235b
MISC metadata.xml 402 BLAKE2B 3fcce3ac9ff731e24a3f6e761da2d840b3a7c9107b3d9a46afe00fed61b475d1400580b4ccf49dd71f6a1ab8098dc2aaf895e529a723cd96301d1400ee211edf SHA512 138106c714dc33871ccf535cc47d669580b665c842adfea5442a03067fe507236d8fde4158f006e1188003abe53c9c25db98632dadd1cfa0e41efd1755c2c75c
diff --git a/dev-python/sybil/sybil-9.1.0.ebuild b/dev-python/sybil/sybil-9.1.0.ebuild
new file mode 100644
index 000000000000..4b7c7c471eda
--- /dev/null
+++ b/dev-python/sybil/sybil-9.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}