summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-01 03:04:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-01 03:04:34 +0000
commitaac5e1b02ac846f5e1ce85f4f66fdec46aa9b0d1 (patch)
treec95b33a77f5b447d4d4e83204c5a846a5c481a08 /dev-python/sybil
parentb846e1a1ef5685462a20abbc77cf57ead9064b85 (diff)
gentoo auto-resync : 01:11:2024 - 03:04:33
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest2
-rw-r--r--dev-python/sybil/sybil-8.0.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 1b1cf40afceb..f82386b5de4e 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,3 +1,5 @@
DIST sybil-8.0.0.gh.tar.gz 75118 BLAKE2B f62f15dab48af23423d8ce9e8a49f3b772fad7d029360d0a98f36a8d2386fc2fc76a2510550ada6b2256848364fa0c998ba939f625c00f1628b8d1a07ad298b5 SHA512 00a02c786e29596fadc3f016c97bc492723fdd956b430ddca2a5e66d38cab424410cf3c74b46f5fff84d3bf3d39ba397068562c5bdca3cff142ce42ad0048487
+DIST sybil-8.0.1.gh.tar.gz 75321 BLAKE2B dc3b4dcafd7d10549d75767a86a32d6509c1fc6683617d533b64bedb9499dfa1405656eed049622d32d9aef13f74e20ba2a46bf5eb57bd8306e086a31353b2cb SHA512 06f0012198e575c0a90274c970880c5fbbcf0738ea57a4cc9692999ea3ad9e40be217e741b3b6ddcfd947f1787c3d60e68ee4d52d547f9929cf3fd2c89880bcc
EBUILD sybil-8.0.0.ebuild 887 BLAKE2B de491417aa76861629588c32945868ee348ec5997b4a4b49b1fcd4ec4ed87cb9bd61aba1c34d49ea5ea6cb7247e1235ecab6b655a62610797ff8985df4f66e8b SHA512 0a336e73e870b11cc14aaf55cd1db2106feb3a669912d80dc4b20c233fcf5f43b1b67c67885bd52975079c53244238612ca91891df4a92ab6eeeacf261553a3b
+EBUILD sybil-8.0.1.ebuild 894 BLAKE2B a8335b14901435f21363f6d6a60723708620fc70d50572b4844f78eff04a4ed1c9e027dac01158f3b1e8a4b2e5982e5dae4469d7c2e624ffe976daaf82ace9ab SHA512 3e4142c50eddf9e0f133b99503238bb4989f6e61b28b3dae6e1bc376fa23f17b694af26e7d84733ae4009e0810b72d74fcc7e20e05a18cb45932712c5065bb16
MISC metadata.xml 402 BLAKE2B 3fcce3ac9ff731e24a3f6e761da2d840b3a7c9107b3d9a46afe00fed61b475d1400580b4ccf49dd71f6a1ab8098dc2aaf895e529a723cd96301d1400ee211edf SHA512 138106c714dc33871ccf535cc47d669580b665c842adfea5442a03067fe507236d8fde4158f006e1188003abe53c9c25db98632dadd1cfa0e41efd1755c2c75c
diff --git a/dev-python/sybil/sybil-8.0.1.ebuild b/dev-python/sybil/sybil-8.0.1.ebuild
new file mode 100644
index 000000000000..6244e3506d0c
--- /dev/null
+++ b/dev-python/sybil/sybil-8.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}