summaryrefslogtreecommitdiff
path: root/dev-python/tagpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/tagpy
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/tagpy')
-rw-r--r--dev-python/tagpy/Manifest2
-rw-r--r--dev-python/tagpy/tagpy-2018.1-r1.ebuild26
2 files changed, 17 insertions, 11 deletions
diff --git a/dev-python/tagpy/Manifest b/dev-python/tagpy/Manifest
index 5dfe561333e7..08cbc72a8ba6 100644
--- a/dev-python/tagpy/Manifest
+++ b/dev-python/tagpy/Manifest
@@ -1,5 +1,5 @@
AUX tagpy-2018.1-readme.rst 725 BLAKE2B f40dbe6ab4f03fe0a6141a03ae6f504d202a5c97d605cb22dfa0b9695374260658f8dde0d49e84de0e7d289bff705beed1244215e70cc7f9d8d587d505322a20 SHA512 0d9cd79986a16ad78e76911f9d3c1b36fb706c74c58e9d29dce817bcf4bbd8b29c9596f1228a0524fdf6538f2c685901a159fd9bd0b629d0dd1d60c75c2820b0
AUX tagpy-2018.1-taglib-1.8.patch 642 BLAKE2B 45c190b621dda7368583c1ab92a01f08fb84d83666953caa5f05c89803db16dc8cd1668e3b891c757c916d27439c4c3143a8a8a2115ad89a8b2f1806dc4a80c9 SHA512 6a3af752fdfd12f6c5f6e52019f3d4f322b9dc3595e810e93ed43e680c1a2f7728efeb8d1180473ca3dfaa7f548d437c32f0a306882ad7f7072388f57ea42caf
DIST tagpy-2018.1.tar.gz 145501 BLAKE2B acdda6789dae000ba2f664e4a5582f6218f312bed20ec81c4ea54f358bec70d41aceed6704f392a7a32c39d263da81f9c832922942fa179e1865e423dcf28bcf SHA512 2010baa919adadc9fc231deeb093953622ec54c8b6011e2d6a3489b086032de0a71cc26f42439435f26bd7a1ff069e3944dafc61217abe6ea5e81b01b9d18c50
-EBUILD tagpy-2018.1-r1.ebuild 1082 BLAKE2B 80fa3e5fb48d8827901eb41a582bb25298c9cc86fedec297ed2e34e7add14b2223c20a6086c72b38806cec3bbd493711f12620b6b021765a101acfafbad33c92 SHA512 9e8801795d514dbc1dea4932d0005196cdeb639b71b53efe0206c5193c6963714c5c8678a65f0b3c3fc4abfb43373d73d2c5fce4a5ea2828d5400a73e915c3b6
+EBUILD tagpy-2018.1-r1.ebuild 1186 BLAKE2B 2a3a321c39967785360ef78ea5bb151b9f6711f4e8154b94dc728e582242156d035a406e6a04a51cbec49b715992b74db213fa941ea5910b6cda92a3f08910d2 SHA512 304e15eca95e5598d45938ec353d729b7ae061f67d8dc12f1ddaf1fb45e419a64c7003bbe3fd3cc03672e8e77fcfe52dd89575fc7d1db5d362889bb8b6afea80
MISC metadata.xml 547 BLAKE2B c5c61e36e108060392467ad7bde0c8869b6df0f55367e528e9165d216f4c9674af13ec580c1b2fe6c231843cddd40b621f816c71e1d718126583085780649d66 SHA512 caf162b52bba166e74c1c1c9a6f157ee44d4b7f829c089dee93b6c84a99c847384ff7cd4f03ce191574e58562fdabe29eb4b00281551227f5d274adc3e7ba2d2
diff --git a/dev-python/tagpy/tagpy-2018.1-r1.ebuild b/dev-python/tagpy/tagpy-2018.1-r1.ebuild
index 35daa217ce97..56a858f2cc9c 100644
--- a/dev-python/tagpy/tagpy-2018.1-r1.ebuild
+++ b/dev-python/tagpy/tagpy-2018.1-r1.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_IN_SOURCE_BUILD=1
-DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
DESCRIPTION="Python Bindings for TagLib"
-HOMEPAGE="https://mathema.tician.de//software/tagpy
+HOMEPAGE="
+ https://mathema.tician.de//software/tagpy
https://pypi.org/project/tagpy/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -20,11 +20,12 @@ IUSE="examples"
RDEPEND="
>=dev-libs/boost-1.70:=[python,threads,${PYTHON_USEDEP}]
- >=media-libs/taglib-1.8
-"
+ >=media-libs/taglib-1.8"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${P}-taglib-1.8.patch" )
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${P}-taglib-1.8.patch )
python_prepare_all() {
cp "${FILESDIR}"/${P}-readme.rst README.rst || die
@@ -34,15 +35,20 @@ python_prepare_all() {
python_configure() {
local boostpy_ver="${EPYTHON#python}"
- "${PYTHON}" configure.py \
- --taglib-inc-dir="${EPREFIX}/usr/include/taglib" \
+ "${EPYTHON}" configure.py \
+ --taglib-inc-dir="${ESYSROOT}"/usr/include/taglib \
--boost-python-libname="boost_python${boostpy_ver/\.}"
}
+python_test() {
+ cd test || die
+ "${EPYTHON}" *.py || die "Testsuite failed under ${EPYTHON}"
+}
+
python_install_all() {
if use examples; then
docinto examples
- dodoc -r test/*
+ dodoc -r test/.
fi
distutils-r1_python_install_all