summaryrefslogtreecommitdiff
path: root/dev-python/tempest-lib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/tempest-lib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/tempest-lib')
-rw-r--r--dev-python/tempest-lib/Manifest3
-rw-r--r--dev-python/tempest-lib/metadata.xml23
-rw-r--r--dev-python/tempest-lib/tempest-lib-1.0.0.ebuild63
3 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/tempest-lib/Manifest b/dev-python/tempest-lib/Manifest
new file mode 100644
index 000000000000..6e940ba77e03
--- /dev/null
+++ b/dev-python/tempest-lib/Manifest
@@ -0,0 +1,3 @@
+DIST tempest-lib-1.0.0.tar.gz 115527 BLAKE2B 4937aaa84ad8b6315bc4db03edb64303a64801fb4915489f0e48262bd52224a047687d2adfb6524273763976053eca5f209d12f93914408f4c21e2e2e69a1171 SHA512 e47716d897c2df4be08b863352cbee986194db00d113a9135d57cc440436c97dea5c009d6a24c4b489360b04585b2a54a9b66a5776d17a988dfb9f0baf57e484
+EBUILD tempest-lib-1.0.0.ebuild 2076 BLAKE2B d7916a12d6b8477dbeb2b40a73ae74898e6798f871564b13082ec542891678b25a6a7e5b24f94d763ece8dc301e35eae34b4b46a521fa51448e0f67d428806f6 SHA512 7bd8137ec96bd56270f0489b90cc04caee9b596d2d57cd687ac6626e56cd9afd5c4bec5d3c8e5f8b6ee55c9919cbb564c9c91926a09a9b0e368e8592c350f87a
+MISC metadata.xml 783 BLAKE2B 14e7df8454923e775a91e481b5c0fb30730fa9d255a9971600351392cc3f3e72d7c02d2bebd4cf0f65e1d02afcd152ccf73ee4de854b5ad0c082c4a2718b1216 SHA512 4c90ae3bab98585854785700c90545fcd89ef89e5f11f8f53a102a67f59342a347f683f98429cec498537a6c2307d36cad3f0f4c9bd0e7f12af75090f8d14dad
diff --git a/dev-python/tempest-lib/metadata.xml b/dev-python/tempest-lib/metadata.xml
new file mode 100644
index 000000000000..e8cdcbed4457
--- /dev/null
+++ b/dev-python/tempest-lib/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+tempest-lib is a library of common functionality that was originally in tempest (or similar in scope to tempest)
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">tempest-lib</remote-id>
+ <remote-id type="github">openstack/tempest-lib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tempest-lib/tempest-lib-1.0.0.ebuild b/dev-python/tempest-lib/tempest-lib-1.0.0.ebuild
new file mode 100644
index 000000000000..a011f7cd8106
--- /dev/null
+++ b/dev-python/tempest-lib/tempest-lib-1.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Functional or integrated test suites for OpenStack projects"
+HOMEPAGE="https://pypi.org/project/tempest-lib/ https://github.com/openstack/tempest-lib"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/os-testr-0.4.1[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.11[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/ddt-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-0.1.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tempest_lib/tests || die "Tests fail with ${EPYTHON}"
+}