summaryrefslogtreecommitdiff
path: root/dev-python/tempest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/tempest
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest4
-rw-r--r--dev-python/tempest/tempest-29.1.0.ebuild66
-rw-r--r--dev-python/tempest/tempest-29.2.0.ebuild66
3 files changed, 136 insertions, 0 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 1fd14337a129..9f4c1abac8d9 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,3 +1,7 @@
DIST tempest-29.0.0.tar.gz 1090497 BLAKE2B 520e9de1fc326d9a64d7ab5e93887f3bd455d9c47d29e0774bfb362b1baff6c1dd13fc6df2c756f0e73dd2b33ecb02ea61abdca9ea1ae68474ba53271c6c9e93 SHA512 03049d6cf0e77bac1afafad88b5b0fd22abaa40ed24ffd2c0c989dbadf277c09d703f0d9f7b34f4f68a4b5858b061ea9586ef66e26749b0822af0e426d1b81a7
+DIST tempest-29.1.0.tar.gz 1091318 BLAKE2B 152900742fe10beebbcec69e20be35d20e3cd652f309de849ee9306e76d0f9dc6508ee2f66a577f6b85578aafc47ccb42b554b796813d845788b57ea49cf7cf1 SHA512 591018fcd6f0fa6ff9343a2f6c855bcd858ab805d9b28585bbdd05e319af74b833d316b64e88e5a53dfc53d58a247beb625c475ee884cfb60205d0f64bf0ba86
+DIST tempest-29.2.0.tar.gz 1092824 BLAKE2B cad7284ab5a5a39a1a5bdf9f2365a85d337e4ebe17243bc3692a98402ef7f11b27b94e0252d9d427f358c343b736b500db5386098950c88b09f23d87de9ad856 SHA512 4042bce9c5d7cd26d652189d82ee91ac43d73a515b690820dfe05b70c2e792ec6f3bb0be5566bb37e81965015f62773414c8a16cc77512b1e52f141eafbd542d
EBUILD tempest-29.0.0-r1.ebuild 1821 BLAKE2B 9a029494e7a6779e0a417803e5347f0ca7bb080a21d94c54abf46ce8763034bfa42c896a60adb7a931e01e5c7f8b78390370042775905223c500500b78d3f40a SHA512 2fbe3eeaef473c8312428491aa0b71113ed960aecf4eedf01863be9b978cb50d2cd13f87eccdbbb9591620f32c3dd7f5ea59a5c9f371df89aec6cd752dbff711
+EBUILD tempest-29.1.0.ebuild 2040 BLAKE2B 2d6aff9239ea19512075291f2ce6ba80417983018eaa462de967129eb8aa2f2fe6b3e7899cab27a75408ef3a4cfa437680313ad30dfe69362ab2fd7eed5f7da1 SHA512 4fcf00ae8dad6388db37a1a9c2f0d64ba8b062ca6ce84490fe613fdddc27cdeb5843383f3e6b2c529e66e5ca7ca6f1a21d1673f8983b01bd59d17799dfa03e00
+EBUILD tempest-29.2.0.ebuild 2040 BLAKE2B 2d6aff9239ea19512075291f2ce6ba80417983018eaa462de967129eb8aa2f2fe6b3e7899cab27a75408ef3a4cfa437680313ad30dfe69362ab2fd7eed5f7da1 SHA512 4fcf00ae8dad6388db37a1a9c2f0d64ba8b062ca6ce84490fe613fdddc27cdeb5843383f3e6b2c529e66e5ca7ca6f1a21d1673f8983b01bd59d17799dfa03e00
MISC metadata.xml 401 BLAKE2B 9a92d6bb9b20f86c1288c52b2a656367779e67602bf3bf1be4a21601f3141e4864916250418ca7bf1f13767f528cd4679fb6e1a18dca1143c3edde50b508cc0c SHA512 ba3015a097340042ba4580d59da46e12f6b34e2ee174c6ae775a5d7b71b4bcfbf04b52fcb871af76e0ec3bf592ec1485f1acdb4944a0a48ae77b6e8b958ac198
diff --git a/dev-python/tempest/tempest-29.1.0.ebuild b/dev-python/tempest/tempest-29.1.0.ebuild
new file mode 100644
index 000000000000..e042bc64305b
--- /dev/null
+++ b/dev-python/tempest/tempest-29.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="https://pypi.org/project/tempest/ https://docs.openstack.org/tempest/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hacking[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment. Others expect to run suite using stestr.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+ rm tempest/tests/test_list_tests.py || die
+ rm tempest/tests/lib/cmd/test_check_uuid.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_TEST_TIMEOUT=320
+ eunittest -b -s tempest/tests -t .
+}
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
diff --git a/dev-python/tempest/tempest-29.2.0.ebuild b/dev-python/tempest/tempest-29.2.0.ebuild
new file mode 100644
index 000000000000..e042bc64305b
--- /dev/null
+++ b/dev-python/tempest/tempest-29.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="https://pypi.org/project/tempest/ https://docs.openstack.org/tempest/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hacking[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment. Others expect to run suite using stestr.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+ rm tempest/tests/test_list_tests.py || die
+ rm tempest/tests/lib/cmd/test_check_uuid.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_TEST_TIMEOUT=320
+ eunittest -b -s tempest/tests -t .
+}
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}