summaryrefslogtreecommitdiff
path: root/dev-python/tempest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-18 23:20:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-18 23:20:40 +0100
commitf39c6dab71f5188f95650d367ece1df4f263e474 (patch)
tree9c30c203b3f09174814c41e6a63aa3522c7b7610 /dev-python/tempest
parent1b295861f983d29f9bd5d5906c7ca3cee4cf1f9a (diff)
gentoo auto-resync : 18:09:2022 - 23:20:40
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest2
-rw-r--r--dev-python/tempest/tempest-32.0.0.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 999b32d42d32..6068318780ef 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,3 +1,5 @@
DIST tempest-31.1.0.tar.gz 1114805 BLAKE2B 29c0f55db6812a4da6bdbce1159a7e5b87ef0caf4b21e0810b6c941633182da12b72675d86ec0f9f2b844d91258439305c059f6f03ed09d45f7758426c6c096f SHA512 56726d5c0aa8d576e3dc200d30a370be08fec178f357381f00ca08883ab1ccf56fbfaa53ec9322a5f4eb5383e0572f25d8cd277848bc0c3a3d12e57722860a2b
+DIST tempest-32.0.0.tar.gz 1121245 BLAKE2B 00cd2bf7f0869f9040134076e93ebb9d7aa56504788484ed0597d024afb74726df64aa2899dc021ba977cc01814e5e2213b46428d969a73d561e0056b5777d84 SHA512 8770a7067439977720916a8221554836c29afcb18f29716dc513c2eb9f5e09d9b7e123bf98dcb70dafb889594c431efb0367187622e5f0561b24e296a3613734
EBUILD tempest-31.1.0.ebuild 2135 BLAKE2B aed4a3c33e8c909f1b40b8d9bb5b13cd38b038b340f0d156ceb6692238f6dfa04d7f2cb69d01728e590c9a16b9312f521ae1be418a9a9d4c846d7216ac77ae17 SHA512 62d4381d73e3d8bffa6e89cf8459553424e4059a09f897f34584d9c517a950531a2869aa1af0a3029fd4f5e17bcd4f01014f259d000397ecaba57de018064070
+EBUILD tempest-32.0.0.ebuild 2138 BLAKE2B c1c17ef2a0cce940b9befaafe8815d4707788a309b6aae90092adb35b7a0421d0b6a9aa886f217f64b097e617411901b49be719d81eaacd8a798dcf60072532f SHA512 9c321710e01ad2ab2181d023820838bc7ecceba6f9e4478d1d582a17e8f830069fb25a560884b52484886a1ae157089f56afe974a09a14514453d81e75d146ad
MISC metadata.xml 392 BLAKE2B cf7565379c5e1bed34940d0771212eea2a7ff81949678e0a645ce4d7d1c3da88febc0bb5a2ca968de8962d63610e37b0f3adc6e0661ae9de8c656d5ce0ae9c0a SHA512 41d760432a3c46d0fce432e6d431cac110e2c271796d0d04ee026347f01ff3add7db90edfdd83397190e5a563f04c835b250052763ea9daae788ac43519a769f
diff --git a/dev-python/tempest/tempest-32.0.0.ebuild b/dev-python/tempest/tempest-32.0.0.ebuild
new file mode 100644
index 000000000000..e5d757d4c5b8
--- /dev/null
+++ b/dev-python/tempest/tempest-32.0.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="
+ https://pypi.org/project/tempest/
+ https://docs.openstack.org/tempest/latest/
+ https://launchpad.net/tempest/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment. Others expect to run suite using stestr.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+ rm tempest/tests/test_list_tests.py || die
+ rm tempest/tests/lib/cmd/test_check_uuid.py || die
+
+ # remove dep on hacking
+ rm tempest/tests/test_hacking.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ mv "${BUILD_DIR}"/install/{usr/,}etc || die
+}
+
+python_test() {
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_TEST_TIMEOUT=320
+ eunittest -b -s tempest/tests -t .
+}