summaryrefslogtreecommitdiff
path: root/dev-python/tenacity/tenacity-8.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-14 18:13:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-14 18:13:29 +0100
commit85dc262ae9ec9413f8172a2a8442d6d9134d02f4 (patch)
tree81768a8b154fded73a17e9475cebc90d79fd4720 /dev-python/tenacity/tenacity-8.2.3.ebuild
parentb6323af2602e6a5cd4920d4af06b5c2f3949b9d0 (diff)
gentoo auto-resync : 14:08:2023 - 18:13:29
Diffstat (limited to 'dev-python/tenacity/tenacity-8.2.3.ebuild')
-rw-r--r--dev-python/tenacity/tenacity-8.2.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/tenacity/tenacity-8.2.3.ebuild b/dev-python/tenacity/tenacity-8.2.3.ebuild
new file mode 100644
index 000000000000..1dfd2761517b
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="
+ https://github.com/jd/tenacity/
+ https://pypi.org/project/tenacity/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ if ! has_version "dev-python/typeguard[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
+ )
+ fi
+
+ epytest
+}