summaryrefslogtreecommitdiff
path: root/dev-python/testfixtures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/testfixtures
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest5
-rw-r--r--dev-python/testfixtures/metadata.xml12
-rw-r--r--dev-python/testfixtures/testfixtures-4.9.1.ebuild57
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
new file mode 100644
index 000000000000..5f302fe68465
--- /dev/null
+++ b/dev-python/testfixtures/Manifest
@@ -0,0 +1,5 @@
+DIST testfixtures-4.9.1.tar.gz 90117 SHA256 e45eef63eb39e63f689ec9d25f03b9bcc201b15e6411f3b73cfe4d0611ad5e1d SHA512 20053d22297b7852382a4f2bf6d76bde6489f788a9073aaae407f68bb6b3d7bdc4a045868cf7c99fd294936768745ee7d652c86a4a96c33fb0e95fa0d96d2a59 WHIRLPOOL 2cabb01d1d11fcf54aac3ba05ed5432bbe0eeb416699b8b4db108a94ce87b1cebe5c5594c350f5e39b1cb4f036dd9577620235b2ddc757ea31c956d3b97f43d3
+EBUILD testfixtures-4.9.1.ebuild 1607 SHA256 ef59d918ae9e5b8e67747538c4e7f0f46c0d7dc5552c1033475e9676fed8a792 SHA512 e9135d4e657d229cdd97a6f4e7f242aaa2941e3bd2e9bcb1f06fd52b4499fb8424bf85e34e3fa5ea537ab0ba22cd706e6420c2013c2c2f8878221409decf69d3 WHIRLPOOL 6c7d4eeb37e8b8093bc42e162c0aac7434bd9c9d94ab6be4751e16ed7e54e3780d8e1f771bcb6711d4021a375d8bdacc8c7bf4fd5cd4bf03b415f3b9c160ea80
+MISC ChangeLog 4703 SHA256 e95f367a5a349e9e6d820c74da634e98b320138452178d6e654d9dd2fdf66e06 SHA512 77ac23179258b3680072c132bdaef3916c785a51eba9076169c8211c927d02e41615b671e51bd0fcf87447e3ad8170eba00ecb63332e952d934a8b726a50174d WHIRLPOOL d5df2143226d5643fa532298795994a93b7f15ff86b768132b9e6b223b65e40688e50dc0fac2e8dd9b5de67f1e7472458911855f9d5eb5c784479f4037059505
+MISC ChangeLog-2015 2414 SHA256 72ee1fe694b8e471324935b086c239be3b9b9c26ffa6b6e32d91221bc44be515 SHA512 cee821950381d707e2ddae6ab226c08c239d0d1d93e2d041e891846495acd3277f7d399645d662251d7e3bd619452e29fa820698c4d9f1f64a5f7df63b807ae0 WHIRLPOOL 2c1a912761d1cd23fdd8cdf14f1417a8974593450df4f436514f59630698b98dad728aa1b06479a7898fd7a0446af33227ba39c7395a00804ea502770f12fea4
+MISC metadata.xml 390 SHA256 b2eaf47f2f53cad3bec7ef0231fc3558bcd1978838ab64b03312e28f369eb796 SHA512 b5acb87f7a097840d861cf348e917f652b81712f9c4b408bd4a3b0f5a7b051bd1731735b2b3f63aa56144a032e6ea54fe3691c5858cb678666b6c4d701088776 WHIRLPOOL cb04b997acc0709f9c16e6431992d1c156e049b173417eb6ed971016c2ed5083cb574bb0959882cb9c6b82a50b9c301829b3e88101fb532bb99cd95033a03c02
diff --git a/dev-python/testfixtures/metadata.xml b/dev-python/testfixtures/metadata.xml
new file mode 100644
index 000000000000..79a3f50dbe78
--- /dev/null
+++ b/dev-python/testfixtures/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">testfixtures</remote-id>
+ <remote-id type="github">Simplistix/testfixtures</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/testfixtures/testfixtures-4.9.1.ebuild b/dev-python/testfixtures/testfixtures-4.9.1.ebuild
new file mode 100644
index 000000000000..8003c5ff1b1d
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-4.9.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.python.org/pypi/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy )
+ )
+ test? (
+ dev-python/manuel[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/nose_fixes[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )"
+
+python_prepare_all() {
+ # Makefile comes set pointing at a wrong location
+ sed \
+ -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' \
+ -i docs/Makefile || die
+ # Prevent un-needed download during build, fix Makefile for doc build
+ sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
+
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}