summaryrefslogtreecommitdiff
path: root/dev-python/testfixtures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/testfixtures
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest3
-rw-r--r--dev-python/testfixtures/metadata.xml12
-rw-r--r--dev-python/testfixtures/testfixtures-4.9.1.ebuild57
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
new file mode 100644
index 000000000000..b7b99f4c131c
--- /dev/null
+++ b/dev-python/testfixtures/Manifest
@@ -0,0 +1,3 @@
+DIST testfixtures-4.9.1.tar.gz 90117 BLAKE2B 6560d4072f8b0108b7d7708c980f40df1a05af88df86dd01926bdf0eab107744fc89d75bdedaced7300c24a52a9d1c0685f5dd3f5f732121ff97af6d0859055a SHA512 20053d22297b7852382a4f2bf6d76bde6489f788a9073aaae407f68bb6b3d7bdc4a045868cf7c99fd294936768745ee7d652c86a4a96c33fb0e95fa0d96d2a59
+EBUILD testfixtures-4.9.1.ebuild 1605 BLAKE2B 12f31e72255a2526b345f3b214820dba784ad3b439e0a2c620332f45458ae684c7a1d8ffe2667573368ac22a4906074d131b04440f0a152d6ab7476e7ecdb310 SHA512 7b25c1077259c12c58b79837bc93b0a0c58d6a4469f8f3f22f7a701cf0bb8ba9c31c7dc6eb851f8f2a23866419e30a6e88f9b86876a2e6ec6f843505080fd79e
+MISC metadata.xml 390 BLAKE2B 7211b89e4130b65db09254857e522420bae09bce05ff1065c6fa53802cddabe3536c8631e2ae79ab63d63f4d2550113e49a5d0834d7ed782524678a38b5c1144 SHA512 b5acb87f7a097840d861cf348e917f652b81712f9c4b408bd4a3b0f5a7b051bd1731735b2b3f63aa56144a032e6ea54fe3691c5858cb678666b6c4d701088776
diff --git a/dev-python/testfixtures/metadata.xml b/dev-python/testfixtures/metadata.xml
new file mode 100644
index 000000000000..79a3f50dbe78
--- /dev/null
+++ b/dev-python/testfixtures/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">testfixtures</remote-id>
+ <remote-id type="github">Simplistix/testfixtures</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/testfixtures/testfixtures-4.9.1.ebuild b/dev-python/testfixtures/testfixtures-4.9.1.ebuild
new file mode 100644
index 000000000000..249371ad9d35
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-4.9.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy )
+ )
+ test? (
+ dev-python/manuel[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/nose_fixes[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )"
+
+python_prepare_all() {
+ # Makefile comes set pointing at a wrong location
+ sed \
+ -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' \
+ -i docs/Makefile || die
+ # Prevent un-needed download during build, fix Makefile for doc build
+ sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
+
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}