summaryrefslogtreecommitdiff
path: root/dev-python/testfixtures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /dev-python/testfixtures
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest2
-rw-r--r--dev-python/testfixtures/testfixtures-6.8.2.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 84fcba2d8a90..1a3b77113c69 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,3 +1,5 @@
DIST testfixtures-4.9.1.tar.gz 90117 BLAKE2B 6560d4072f8b0108b7d7708c980f40df1a05af88df86dd01926bdf0eab107744fc89d75bdedaced7300c24a52a9d1c0685f5dd3f5f732121ff97af6d0859055a SHA512 20053d22297b7852382a4f2bf6d76bde6489f788a9073aaae407f68bb6b3d7bdc4a045868cf7c99fd294936768745ee7d652c86a4a96c33fb0e95fa0d96d2a59
+DIST testfixtures-6.8.2.tar.gz 110838 BLAKE2B 4b83a1459aec4bc4b4dcdff48603958bfd115806ce0c567faad37ac273e93096cf964af08d24b98c1743d6302d1b2f6f9c9498023c781ab3e9170e2eda74cefe SHA512 ce6561d976a0b8f79ae72aaca6f5ffa8d1cae30ad73d3d88625ed4fe55da5f0a913785fa3e9aeb4268dfb243a7b74dddc262554521a71c766089383aa5b0e022
EBUILD testfixtures-4.9.1.ebuild 1600 BLAKE2B 6d83ba2f3f7d67f65c7ba3bbc1d79a3e2dfdfa8ab1a3f4c883a4915dc403dc5fa41cf0834748abe368ad36480886b3c255cd7d937749d255d80df132b45854aa SHA512 a32b2f7f83745d2767d89ff3a33c11316612cfa416966f8abda19218c8a32fbb4c1bad9a6fe4234f7858141f1ee6a5ac6799cd8fc3afd4abb11c6279fea4c4f8
+EBUILD testfixtures-6.8.2.ebuild 1595 BLAKE2B 976b4a2390abf33da8d760eb5aca582d9c619e8424d38cd7dbc1b53c606952a44f505bb483e762cab4235031d9cbb64d3f24d86cb82ecb06e8cdef64970ca4f3 SHA512 aa3d988517face2068dc11c03d0a2e0fd7f10ed9f1f813c55fe3be117c1d972ee0ae40dce15e5c091a17f5f592bff87268d06f97e35b689f3e5c53626a51f582
MISC metadata.xml 390 BLAKE2B 7211b89e4130b65db09254857e522420bae09bce05ff1065c6fa53802cddabe3536c8631e2ae79ab63d63f4d2550113e49a5d0834d7ed782524678a38b5c1144 SHA512 b5acb87f7a097840d861cf348e917f652b81712f9c4b408bd4a3b0f5a7b051bd1731735b2b3f63aa56144a032e6ea54fe3691c5858cb678666b6c4d701088776
diff --git a/dev-python/testfixtures/testfixtures-6.8.2.ebuild b/dev-python/testfixtures/testfixtures-6.8.2.ebuild
new file mode 100644
index 000000000000..9944852b60cd
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-6.8.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy )
+ )
+ test? (
+ dev-python/django[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build, fix Makefile for doc build
+ sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
+
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py docs/components.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="." \
+ DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings \
+ pytest -vv || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}