summaryrefslogtreecommitdiff
path: root/dev-python/testfixtures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 15:14:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 15:14:18 +0000
commitf5f1e7d30401ef31b8776c96a80cf5caae0a4e81 (patch)
treecf79465586b83d032475fad7f33894f6cf4efd1f /dev-python/testfixtures
parent0bb8253b38dc8638a46b66ba909c1bfd1054e1ef (diff)
gentoo auto-resync : 04:11:2022 - 15:14:18
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest2
-rw-r--r--dev-python/testfixtures/testfixtures-7.0.3.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 1f7c5af29218..f94a4800c982 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,3 +1,5 @@
DIST testfixtures-7.0.0.tar.gz 126163 BLAKE2B e9f31180878e7645a62b93242344c6cd8335067cf8158b03dbfb46b4ab79d57380809a20d6fdc6a6d4b0aca2d22f5d7c18636607a54c70de4bea39e79a9df6b1 SHA512 5fe56e0a654586c266aab5cebcdbf1e6b9988227605395c3198c759759be0fa98ff3c0a1885711ede5ef6d262a60cd19a29dc6e7a90a1f9f8b57df3cb2d9b97b
+DIST testfixtures-7.0.3.tar.gz 127280 BLAKE2B 14725f5a04a77453f1a6e1cb07b2ee8e907dcf49a845c9c75951d77160448c1037c7bfa0a759cf4061d92448203b8f4b14d611cdde32f46269b484985e654e67 SHA512 875aba5102bd43800b2f6464dc93185cd2bb5e117523cb4b3c458b2f8f8eb71f309c0a5266eeca70a7928f9992ccfe7807c67e42531c17fd82ca1c3b838d02a5
EBUILD testfixtures-7.0.0.ebuild 1309 BLAKE2B e36f0bbe797a2bd27e3b4a8f192196bc2ddedd5b823eb488b951b296115bbc2cdd7d27e73902a70feebabbcdb1f429fc2193b85c26d09a28e7eb2577cc32a42d SHA512 b8d55688da3922d7bd3c03753a596b189f59981d3d86a31aa51a91796cccda3b7888166a4f47595eda1d4fbb77932b8ba14b79c9dea6cd9d01d1203210a41d6a
+EBUILD testfixtures-7.0.3.ebuild 1312 BLAKE2B 1080faecee935533c3477f6e7757e38e337babe3aecc67b3163a89c38f992df1b6ebc611905a79d147c3794a1ad555e467b27060ac509463b0ab35968656f786 SHA512 1bb689497c182537d7c7041311634895a1608836a029b2d82aef7ab3240ea9c259cda6971189628470e0992cd8b0f3017f95e591a03cf9a05fcfa8cabcbdabe2
MISC metadata.xml 416 BLAKE2B 19f5d275458874364d2719ecf363f7a5627f9e612b7d3a3f2c075e306063ed899dec0b2e59ea5e5d7ba65209c9a6d91045d80b2fe50e74278e61247d0426b940 SHA512 8a5776feee4d6758da67dc0b413e2d0ddc0c843075ca96c9b44adace1f7669a6abf820c5b73b86652b27e9feed19a4a30e1004a021b24bda0829b5690a1687ec
diff --git a/dev-python/testfixtures/testfixtures-7.0.3.ebuild b/dev-python/testfixtures/testfixtures-7.0.3.ebuild
new file mode 100644
index 000000000000..8d96b3520597
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-7.0.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/
+ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # kill weird way of declaring build deps
+ sed -e '/build=/d' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ epytest
+}