summaryrefslogtreecommitdiff
path: root/dev-python/testpath/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/testpath/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/testpath/files')
-rw-r--r--dev-python/testpath/files/testpath-0.2-setup.py.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/testpath/files/testpath-0.2-setup.py.patch b/dev-python/testpath/files/testpath-0.2-setup.py.patch
new file mode 100644
index 000000000000..a1bf41acd352
--- /dev/null
+++ b/dev-python/testpath/files/testpath-0.2-setup.py.patch
@@ -0,0 +1,28 @@
+Patch to bring back setup.py from
+https://github.com/jupyter/testpath/blob/086bd1bd1ec7da1b3dacfed1705c0c99fae231b3/setup.py
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,22 @@
++from distutils.core import setup
++
++with open("README.rst", "r") as f:
++ readme = f.read()
++
++setup(name='testpath',
++ version='0.1',
++ description='Test utilities for code working with files and commands',
++ long_description = readme,
++ author='Thomas Kluyver',
++ author_email='thomas@kluyver.me.uk',
++ url='https://github.com/takluyver/testpath',
++ packages=['testpath'],
++ classifiers=[
++ 'Intended Audience :: Developers',
++ 'License :: OSI Approved :: MIT License',
++ 'Programming Language :: Python',
++ 'Programming Language :: Python :: 2',
++ 'Programming Language :: Python :: 3',
++ 'Topic :: Software Development :: Testing',
++ ]
++)
+\ No newline at end of file